1.12 ic2 oled Arduino library

Hi, I just bought the 1.12 ic2 oled display. It says it is compatible with Raspberry Pi and Arduino but I can’t find any info for the Arduino.

Can you tell me what library is best please ?

Looking at the install instructions it appears to be an SH1106 OLED.
maybe this will help
Alternatively do a search for SH1106 OLED arduino library.

The data sheet says it’s an SH1107

Ok, I went here, https://shop.pimoroni.com/products/1-12-oled-breakout?variant=29421050757203
And noticed
With the I2C version, you can run an example like so: python3 maze.py --display sh1106 --height 128 --rotate 2 --interface i2c
In the software install section.
So have a search for an SH1107 Arduino library and see if it works…

Thanks. I won’t have much time over the next couple of weeks so I’ll test it with the Pi version and try the Arduino at some point.

I still haven’t had a meaningful response to this question. I am trying to connect the screen to an Arduino UNO. Everything on the internet points to the U8g2 library but that doesn’t work for me. Can I have a response please

You might be on your own Arduino Wise. Pimoroni are mainly Pi / Raspbian oriented.
I buy a fair bit from Adafruit and equally frustrating they are Arduino / Microcontroller orientated. I get the other side of the coin there. I’ve bought a few breakouts there that had all kinds of code and hookup info for Arduino but next to nothing Pi wise, other than a “the code can be ported to work with a Raspberry Pi” comment. But it’s left up to you to do it, or hunt something up on the internet.
I feel your frustration, I really do, just don’t wait too long for an answer here.
You might actually get some help if you post on the Adafruit forum. Even though it is a Pimoroni product. They sell a fair bunch of Pimoroni products on thier site. They may even have something very similar to that display on thier site with working code. I am a member of thier forum, same username I use here.

I found out what the issue was with the U8G2.
It doesn’t work with version of Arduino IDE installed on the Raspberry Pi.
I haven’t had much chance to look at this with work and Christmas etc. I decided to try it today on my laptop and the U8G2 library works with most of the example sketches.
I haven’t had chance to work out why it doesn’t work with some example sketches but it’s probably down to missing libraries.

I’ll consider this issue closed.

Thanks again

I’ll have to keep that in mind, I have plans to do some Arduino programing from my Pi 4B. May I ask how you installed the IDE? The instructions I have are as follows
From a terminal window

wget https://downloads.arduino.cc/arduino-1.8.9-linuxarm.tar.xz
tar -xvf arduino-1.8.9-linuxarm.tar.xz
cd arduino-1.8.9
sudo ./install.sh

I didn’t use that method. I tried to use the instructions in Raspberry Pi Magpi magazine.
I tried to install v1.8.10 but it would not install.
I used the version that the nstalls with apt-get install arduino

Word is on the Pi forums is that the apt-get install is a really old version. Which was why I asked. The instructions I posted above were recommended instead. I haven’t tried them yet though.

I just did the install. I got some errors right at the end but it still launched. No such file or directory cannot remove errors. Cleaning up phase I think?

EDIT: I didn’t plug an Arduino in, didn’t have one handy at the time, just so you know.