7” Touch Screen - rotate screen issue

I’m using noobs, but if your theory relates to safe mode I’ve already put avoid_safe_mode=1 into config.txt

Also just found out that the leg of the stand is in the way of the USB ports. So far not pleased with this product!

I think I’m going to have to set up NOOBS and investigate- I know lcd_rotate works on the raw Raspbian Jessie and Raspbian Wheezy images so it’s likely something to do with NOOBS.

We took a calculated risk with that decision- figuring most people would plug at least a WiFi dongle and possibly also a wireless keyboard dongle into those ports.

The upside-down-ness was unavoidable, since a software update rotated the display after we’d already created the stand, and we ( or at least I, I don’t want to throw anyone under the bus ) still believe this way is the right way up due to the HDMI, power and audio cables.

Was this a NOOBS that came on a NOOBS SD card, or did you install it yourself from the downloads here: https://www.raspberrypi.org/downloads/noobs/

It was on a NOOBS SD Card

Okay! I’ve managed to replicate the problem, that’s a good first step. It’s definitely something to do with NOOBS, although I’m really not sure what. I’m guessing NOOBS has a slightly different initial image that doesn’t support the lcd_rotate command.

I can’t fix it, but I can report the problem to people who can.

In the meantime you could fix it by installing Raspbian, but if you’re using NOOBS for multi-boot then that’s not much use to you.

I’m going to try downloading the latest NOOBS and see if I can use it to patch up my SD card.

Edit: Okay, don’t try that. It broke. Really, really, broke! They’re not kidding when they say RECOVERY_FILES_DO_NOT_EDIT

Just to add to the confusion:
I downloaded NOOBS 1.4.2 yesterday and put it on a SD card.
Initial run has to be done with a HDMI or Analog display connected in order to install Raspbian.
I had both connected and the 7 inch display remained dark.
On first boot, the HDMI display showed the initial rainbow and then the NOOBS ‘press shift’ to enter recovery.
Then Raspbian booted on the 7 inch display. Of course upside down (RPi2 HDMI/USBpower/AV connectors at top).
Added lcd_rotate=2 to /boot/config.txt and rebooted (no HDMI connected).
Note that the Raspbian FAT32 boot partition is the 3rd partition on the SD card. The first 2 are for the NOOBS recovery.
Raspbian came up right side up on the 7 inch. No initial rainbow display, since that goes to the HDMI.
My guess, you are using an older version of NOOBS. This one (1.4.2) includes the 25.09.2015 4.1 kernel and boots straight into the desktop (=Jessie).
Curious to know what the explanation is.

I’ve just set up the new version of NOOBS to try this for myself.

It’s definitely odd. No rainbow screen on the LCD, and boots up by default with Overscan on- causing havoc with the touchscreen etc.

I can confirm that lcd_rotate=2 does work, too.

NOOBS adds a disable_overscan=0 to the bottom, plus a whole bunch of overscan settings. All the settings above need set to 0 in order to turn it off- disable_overscan=1 doesn’t seem to work. The LCD should probably ignore overscan altogether anyway since it doesn’t apply or make any sense whatsoever.

the version I have installed just boots with the ‘rainbow screen’ really small in the top right corner of the touchscreen, it also had those wierd overscan defaults too.

That ‘really small in the top right corner’ rainbow screen is actually the low voltage warning. What power supply are you using, and how is your Pi connected to the touchscreen for power?

Does the rainbow stay, or just appear at boot?

just at boot. I’m using an official raspi psu. 5V 1A.

Something else, but related.
It is possible to get the NOOBS screens on the 7 inch display.
See this post on the Raspberry Pi forums (two files have to be replaced on the SD card before first boot):
https://www.raspberrypi.org/forums/viewtopic.php?p=823236#p823236

I have the same issue, is there a fix yet?

Thanks

There’s no fix I’m aware of yet. Other than the one @tvoverbeek posted, starting fresh with the new NOOBS as of 2015-09-24, or simply installing the Raspbian onto an SD card and using that.

I don’t know enough about how NOOBS works to know if it’s even possible to fix already setup cards, and unless you absolutely need NOOBS for multi-boot I’d suggest backing up your files and installing Raspbian Jessie to stay ahead of the curve- major updates have a tendency of breaking more than they fix.

OK, Thanks very much
Simon

I was having the same issue, the screen was rotated 180 degrees. I tried adding lcd_rotate = 2 to the end of my /boot/config.txt and nothing happened. I am running an updated version of Raspian Wheezy.

On a whim I moved the lcd_rotate = 2 line to the top of the file and it worked!

Great idea daveculp, I tried with NOOBS and it works as well. Just moved lcd_rotate=2 to the top of the file :-)

Thanks

I can also confirm that moving the lcd_rotate=2 to the top of the config file works. It needs to be above everything, even the comments.

I cannot connect 7 inch display to Picky B+?
I only get light on the display.

are you describing the ‘white screen’ symptoms described here:

http://forums.pimoroni.com/t/official-7-raspberry-pi-touch-screen-faq/959

Either way, I would advise to open a new topic, or post details of your problems there, ths one being about screen orientation specifically.

Hi!

First of all, sorry for my litle English!

My problem is that I’ve rotated the screen with the lcd_rotate=2 option, and the video is OK, but now my touch function has turned in flipped configuration, too. So, when I move my fingers from left to right, the mouse pointer is going from right to left, and the same issue appears with top and down…

How can I solve it?

Thanks!

Jordi

– EDITED –

Not sense… I’ve confused lcd_rotate=2 with screen_rotate=2. So I’m sorry for my mistake…

Thanks!!!

Jordi