Automation HAT Mini : Display issue

Hello folks!

Just installed the Automation HAT library from the link on the product page.

I’m trying to use the display, but the examples in the package appear to be for the older Automation HAT. I spotted that @gadgetoid has added a hat-mini folder to the Github Repo, so I downloaded and tested It produces an error as module ST7735 is missing.

Is the package on pip out of date? Or is there something I’ve not twigged?

Any suggestions much appreciated!

Good evening.

Have you ever resolved this problem ?
I find myself in the same situation.

I try to install automation hat mini on a raspberry pi zero with buster light.

The procedure on the site installs a working system for the “normal” hat and for the phat.
Not for the mini apparently.

Have a nice day.


Hello ,
I have a solution to our problem,
After loading the automationhat library
I have, as you , all right but exept screen.
To solve, i have loaded enviroplus-python library.

curl -sSL | bash


After reboot
Examples in hat-mini are ok
And example works perfectly with automationhat
I hope will be for you the same

1 Like

Hi Guys, I have followed your advice, but only after I tried installing other ST7735 libraries. Now when running any of the hat-mini scripts I get the same error:
python /home/pi/Pimoroni/automationhat/examples/hat-mini/

This Automation HAT Mini example toggles and displays the
status of the three 24V-tolerant digital outputs.

Press CTRL+C to exit.

Traceback (most recent call last):

  • File “/home/pi/Pimoroni/automationhat/examples/hat-mini/”, line 48, in *
  • cs=ST7735.BG_SPI_CS_FRONT,*
    AttributeError: ‘module’ object has no attribute ‘BG_SPI_CS_FRONT’

Anyone know why this is happening?

Yeah incase anyone is interested, I fixed this by clean installing a new Raspbian image and then loaded the enviroplus-python library first like @Heride mentioned above. Thanks for that

As is usual with anything linux, it still didn’t work straight away and I got error messages when trying to run any of the hat-mini python scripts. The images could not be found but I then fixed this by adding the full path to the text and not just “/images/xxx123.jpg” .

I am glad that it now works (I still have an issue when running the script - Line 71 - most likely to do with a missing font, but I can’t be bothered to fix that now. I just remmed it out until I have the strenght to tackle this again).

I am just a bit let down that the Pimoroni crew expects everyone to know how to fix these issues and it is kind of a barrier to entry for newbies like myself. Also, no one from Pimoroni officially responded to this thread. I just feel like they bring out such innovative and fun products, but once you buy it you are on your own.

Anyway, I hope my fix helps someone else get joy out of their Automation hat mini

Thanks, You’re the best!