Automation HAT Mini : Display issue

Hello folks!

Just installed the Automation HAT library from the link on the product page.

I’m trying to use the display, but the examples in the package appear to be for the older Automation HAT. I spotted that @gadgetoid has added a hat-mini folder to the Github Repo, so I downloaded and tested output.py. It produces an error as module ST7735 is missing.

Is the package on pip out of date? Or is there something I’ve not twigged?

Any suggestions much appreciated!

Good evening.

Have you ever resolved this problem ?
I find myself in the same situation.

I try to install automation hat mini on a raspberry pi zero with buster light.

The procedure on the site installs a working system for the “normal” hat and for the phat.
Not for the mini apparently.

Have a nice day.

Guibert

Hello ,
I have a solution to our problem,
After loading the automationhat library
I have, as you , all right but exept screen.
To solve, i have loaded enviroplus-python library.

curl -sSL https://get.pimoroni.com/enviroplus | bash

See https://github.com/pimoroni/enviroplus-python

After reboot
Examples in hat-mini are ok
And example lcd.py works perfectly with automationhat
I hope will be for you the same
Great

Hi Guys, I have followed your advice, but only after I tried installing other ST7735 libraries. Now when running any of the hat-mini scripts I get the same error:
python /home/pi/Pimoroni/automationhat/examples/hat-mini/output.py
output.py

This Automation HAT Mini example toggles and displays the
status of the three 24V-tolerant digital outputs.

Press CTRL+C to exit.

Traceback (most recent call last):

  • File “/home/pi/Pimoroni/automationhat/examples/hat-mini/output.py”, line 48, in *
  • cs=ST7735.BG_SPI_CS_FRONT,*
    AttributeError: ‘module’ object has no attribute ‘BG_SPI_CS_FRONT’

Anyone know why this is happening?
Thanks!