Better way to config the Arcade Buttons?!

Why hello there everyone!
I’ve decided to finally order me (and my kids) a Picade to pass time, my wife and I got all put together and all. I already had a Raspberry Pi 3 with Retropie installed and a bunch of games already installed.

But when I go to configure the joystick and buttons for whatever reason it’s reading them like weird keys on a keyboard. (Yes I know that the picade controls are pretty much a keyboard)

But if I press lets say the first left corner button to be A it shows I’m pressing KEY LEFT CONTROL as shown on the picture below.

So I didnt think much of it but if I try to play ANY game, specially old arcade fighting games like Street Fighter, none of the buttons work except for Weak Punch and Weak Kick and somehow they are the two buttons in the middle :(

So I said ok… weird but ok!
I went into RetroArch and decided to map them like that BUT that overrides the existing keyboard I have already mapped in order to navigate into Retropie settings.

Is there a better or official way to map the buttons of the Picade to work correctly?
I thank you all in advanced for taking the time to read this.

This is the picture of me trying to config the buttons on RetroArch, yes I know it says Player 2, I tried Player 1 also but like I said, it overrides the main keyboard I have set up.

  1. If you’re on EmulationStation, press F4 to go to the Command Line Interface.
  2. Download the script, and launch it:

curl -o bash

  1. The script will automatically download the joystick-selection scriptmodule and install everything you need. After installation you can safely delete the file:


  1. After that you are ready to use it via RetroPie menu in emulationstation:


I typed: " curl -o bash" but nothing happened

Hi Nahual,
The ‘weird’ keys that some of the arcade buttons produce is what the XHAT driver does, so what you’re seeing in the Configure Input wizard is standard. I’m not certain why Pimoroni chose these keys, but it may be to avoid clashes with keys that are pre-defined in Retroarch.

I don’t play arcade fighting games, but I’ve tried about 20 other arcade games and they all work. Have you tried any one or two button arcade games? If these don’t work, you may have gone wrong somewhere in the setup or configuration.

If you can’t progress, one workaround may be to edit the key inputs in the arcade emulator rather than Retroarch. You should be able to do this by connecting a keyboard and then pressing Tab while the game is running. You can then edit the inputs for all games, or just the game currently playing.

ps. I’m not sure what Lewis’s script is supposed to do, it’s the first time I’ve come across it.

Thank you!
Yeah, Ive been remapping the controls in the emulator instead of Retroarch.