Can't flash eMMC on Compute 4 mod

Hi There,

Ive been trying to flash the eMMC on Compute 4 mod on a 32GB board. I’ve added the jumper to the first link on J2, installed libusb-1.0-0-dev ( it’s an Ubuntu PC), powered the IO board up with 12V (red LED on IO board) but the host PC doesn’t see the eMMC as a Mass storage device when I plug a USB cable into J11.

Another issue is, when I Clone the GIT repository and run “make” bash returns “command not found” even though I am in the usbboot directory

Am I doing something wrong or is the IO or Module faulty?


Good day ,and welcome ,I don’t have the knowledge to tell you how to fix your issue, so i’ll just post a link to a site with the info to help you ,good luck and enjoy!
I’m posting a link that offers help for when things go wrong ,this link offer help to redo when having issues ,with both windows and Linux ,you may have used already

Try it “without” the jumper on J2. I believe you only set that jumper if your CM4 doesn’t have eMMC, or you haven’t flashed it yet / not using it.
Flashing the Compute Module eMMC - Raspberry Pi Documentation

  • Make sure that nRPI_BOOT which is J2 ( disable eMMC Boot ) on the IO board is set to the ‘EN’ position.