Can't get the vertical line | to type on my Pi Zero W. Wanting both mouse and keyboard to work at the same time also


#1

I’m trying to install the Blinkt! software on my recently purchased Pi Zero W Starter Kit terminal. My keyboard doesn’t allow me for some reason to type this line |. I’ve tried changing to different US and UK keyboards in the settings. Also, whats the best way to run both a mouse and keyboard at the same time on a Pi Zero? Your help is much appreciated.


#2

I use this on my Pi Zero’s, https://shop.pimoroni.com/products/three-port-usb-hub-with-ethernet-and-microb-connector
Press the physical | key on the keyboard and note what character actually shows up. Then go and press that key on your keyboard and see if you get the |. For me the @ and " get swapped if I leave it at the default UK keyboard layout. Switching it to US fixes it though. If your SSHing in you can’t change the keyboard layout, it has to be a physical keyboard attached to the Pi.


#3

Another option would be to follow our headless Pi tutorial and then SSH into it from your laptop/desktop, and then copy and paste the command into the terminal on your laptop/desktop.

https://learn.pimoroni.com/tutorial/sandyj/setting-up-a-headless-pi