Flotilla installer not working on "buster"

Hi,

I thought I’d have a play with my new Pi4 and Flotilla… computer says no!

"Finalising Install…

We will now check that your dock is running the latest firmware

— Warning —

The installer
does not work on this version of Raspbian.
Check https://github.com//
for additional information and support

All done! Time to set sail.

Press Enter to continue…
pi@gav-pi12:~ $ "

Hopefully a quick fix?!

Cheers,
Gavin.

Hello
I wanted to know if you can use your dock on cookbook
because when I wanted to try that do not work he did not detect the
Flotilla thanks in advance
hope for a quick answer
(if there is a fault of the aurtographer, go and complain to google translation)

Yes I had the same problem. I have a post in this forum asking if there is going to be any further development of the flotilla platform as it has not been supported since Rasbian stretch, which is disappointing.

1 Like

I got a reply from Pimoroni Support (I e-mailed them since none of them picked up on this thread)…

"Thanks for letting us know that the Flotilla installer’s not working with Buster - I’ll give our software team a nudge for them to update it.

In the meantime, hacking the script seems to work! I managed to get the installer to run on a Pi 4 by grabbing the install files by running the following:

git clone https://github.com/pimoroni/flotilla-offlinecd flotilla-offline
cd flotilla-offline

​And then editing the install.sh file so that the line that currently reads:

case “$RELEASE” in
“9.0” | “9.1” | “9.2” | “9.3” | “9.4” | “9.5” | “9.6” | “9.7” | “9.8” | “9.9”)

is changed to
case “$RELEASE” in
“9.0” | “9.1” | “9.2” | “9.3” | “9.4” | “9.5” | “9.6” | “9.7” | “9.8” | “9.9” | “10”)

You can then run sudo ./install

to install the drivers :)"

1 Like

Thanks that is great I will give that a go cheers.

Worked a treat thanks very much