Flotilla launched at System Start and blocking everything


#1

After installing flotilla on my Pi, everytime I start the system the flotilla server starts showing the message:

Flotilla Ready to Sail…

But then I cant do anything. While I was on my network from another computer I could connect to my Pi through SSH and kill the server and then I could go on with I was doing but today I brought my Pi to another network where the WiFi wasnt configured and I cant get pass the Flotilla Server since its launched at start up.

How can I kill it? I tried Ctrl-C but it doesnt work. How can I avoid it is launched at system start?

Thanks in advance!


#2

The server spits out debug/info to stout, which will indeed hog the console, depending on what OS you are running (my hunch is you are on Wheezy?).

… I think the plan is to redirect those to free up stout, or possibly recompile it to create a logfile. Either way this is something that needs sorting out.


#3

Yes is Raspbian Wheezy.

So no way to kill it, over pass it, or avoid launch at System Start?


#4

sure, you can delete /etc/init.d/flotillad and kickstart Flotilla with /usr/bin/flotilla when you need it.


#5

All right, I’ll disable it when I’ll manage to login at my network.


#6

I think there is a solution in sight, to stop the flotilla daemon hogging the console (preventing login on boot up) on Wheezy.

If you would like you can try the version at my test repo:

http://github.com/RogueM/flotilla-offline


#7

I’ve been working on a daemonized version Flotilla which we should be able to drop-in. My last step is to add program options to override the daemonize process so you can optionally run it as a standalone binary and see the output.


#8

For the moment I have disable the service from running at boot.


#9

I’ve got a new fork ready of Flotilla which includes proper fork/detach/fork Daemonization which should make sure Flotilla never hogs a controlling terminal. It also includes options for specifying the log/pid files and just running as normal with all output into the terminal. Choices!

Presumably you’re running Wheezy? I’ve got a Jessie binary ready, Wheezy is coming soon!


#10

All right, thanks. I’ll wait for the Wheezy version, no hurries since right now its working fine on both Raspis.


#11

Don’t forget the old adage; if it ain’t broke, break it!