GL Driver and 8" Screen


#1

Does anyone else find that their Picade 8" display stops working if you enable GL Drivers (in advanced mode within raspi-config)?

I am also curious to know if the same happens with the 12" screen (if someone with one would be kind enough to try please? If it works then it’s another excuse to source this larger screen)

I’m trying to set up the full Minecraft version for my kids on the Pi using these instructions: https://www.raspberrypi.org/forums/viewtopic.php?f=78&t=137279, but as soon as I enable GL Drivers and reboot, the screen doesn’t display anything.

Replacing the HDMI out to my monitor instead works ok. I also powered the display from another source in case GL Drivers were ignoring the /boot/config.txt hdmi_force_hotplug=1 option.

Going back to advanced mode and turning off GL Drivers makes the display work again.

Could it be the resolution is just too small?


#2

You don’t seem to be alone with this problem: https://github.com/anholt/linux/issues/28

There’s a suggestion of avoid_warnings=2 to /boot/config.txt but i’m not sure if that will help.

I’m guessing it’s breaking auto-detection of the monitor resolution. It might help to manually specify the group and mode, I think they may be:

hdmi_group=2
hdmi_mode=16

#3

Thanks, I’ll give those a go later - just in the middle of swapping to Picade HAT atm. :)


#4

ah well, unfortunately those HDMI settings didn’t work, but thank you for the suggestions.