Hyperpixel4 Black screen, touch working

Heya!

I have been trying to get my hyperpixel4 weirdly square screen working for about a week now,
I have tried multiple sd-cards, powersupplies and even another screen.

I install a fresh raspberrypi os (32 bit)
Run trough the setup, update the pi and reboot.
After that i have tried running the one line installer but also the getting the specific branch and installing from there.

Sadly whatever i do when i reboot the pi it starts with a blanc command line (only a flickering "_"in the top right) followed by a Welcome to the raspberry pi os desktop screen.

After that its turns black.

I did however find that the touchscreen seems to work as i can see the mouse moving when i open the pi-os using vnc

doing Systemctl enable hyperpixel4-init
gives me the following message: Failed to enable unit: Unit file hyperpixel4-init.service does not exist.

I am trying to do this on a raspberry pi zero W

Hope you guys can help me.
Any advice is welcome!

Platform Information

Revision : 9000c1
Description: Raspbian GNU/Linux 11 (bullseye)
5.10.63+

Touchscreen logs

Rectangular: Goodix
Square: ft5
[ 46.563546] edt_ft5x06 11-0048: supply vcc not found, using dummy regulator
[ 46.581593] input: generic ft5x06 (11) as /devices/platform/i2c@0/i2c-11/11-0048/input/input2

I2C Devices and Mappings

/dev/i2c-11
/dev/i2c-2
Error: Could not open file /dev/i2c-1' or /dev/i2c/1’: No such file or directory

Boot Config

For more options and information see

Raspberry Pi Documentation - Configuration

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode

#hdmi_safe=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border

#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=1280
#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output

#hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)

#hdmi_group=1
#hdmi_mode=1

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes

#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

dtparam=i2c_arm=off
#dtparam=i2s=on
dtparam=spi=off

Uncomment this to enable infrared communication.

#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on

Automatically load overlays for detected cameras

camera_auto_detect=1

Automatically load overlays for detected DSI displays

display_auto_detect=1

Enable DRM VC4 V3D driver

dtoverlay=vc4-kms-v3d
max_framebuffers=2

Disable compensation for displays with overscan

disable_overscan=1

[cm4]

Enable host mode on the 2711 built-in XHCI USB controller.

This line should be removed if the legacy DWC2 controller is required

(e.g. for USB device mode) or if USB support is not required.

otg_mode=1

[all]

[pi4]

Run as fast as firmware / board allows

arm_boost=1

[all]

dtoverlay=hyperpixel4
enable_dpi_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x5f026
dpi_timings=720 0 20 20 40 720 0 15 15 15 0 0 0 60 0 36720000 4

Try Buster instead of Bullseye. You can get it here under Raspberry Pi OS (Legacy) if you don’t have it.
Operating system images – Raspberry Pi
The Pi imager will also give to you if you select “Raspberry Pi OS Other” and scroll down the list.