Issue with phat dac/pizero


#1

Hello

When i run curl -sS get.pimoroni.com/phatdac | bash the second time, i get the following message:
Playback open error: -16,Device or resource busy

below my config

thanks for your help


ls /dev/i2c*
ls: cannot access /dev/i2c*: No such file or directory

uname -a
Linux raspberrypi 4.1.18+ #846 Thu Feb 25 14:11:56 GMT 2016 armv6l GNU/Linux

cat /etc/os-*
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL=“http://www.raspbian.org/RaspbianBugs

lsmod
Module Size Used by
brcmfmac 192598 0
brcmutil 8869 1 brcmfmac
cfg80211 479279 1 brcmfmac
rfkill 21508 2 cfg80211
snd_soc_hifiberry_dac 2911 1
snd_soc_pcm5102a 2101 1
snd_soc_bcm2708_i2s 7654 2
regmap_mmio 3556 1 snd_soc_bcm2708_i2s
snd_soc_core 167413 3 snd_soc_hifiberry_dac,snd_soc_pcm5102a,snd_soc_bcm2708_i2s
bcm2835_gpiomem 3703 0
bcm2835_rng 2207 0
snd_compress 8865 1 snd_soc_core
snd_pcm_dmaengine 5794 1 snd_soc_core
snd_pcm 92829 4 snd_soc_core,snd_soc_hifiberry_dac,snd_pcm_dmaengine
snd_timer 22164 1 snd_pcm
snd 67534 5 snd_soc_core,snd_timer,snd_pcm,snd_compress
uio_pdrv_genirq 3526 0
uio 10078 1 uio_pdrv_genirq
i2c_dev 6386 0
fuse 86348 1
ipv6 358702 24


#2

It looks to me that the on-board audio is still loaded, have you rebooted?


#3

yes, i have rebooted

the point is i have run the script and check all the parameters.

Have you tested the phat dac/pizero on jessie?
thanks


#4

yes, that is the primary environment we support.

the message you are receiving means there is another process that has claimed the hardware, have you installed shairport or similar?


#5

No i have installed squeezeslave only


#6

right, but isn’t squeezeslave running as a server? stop the service if you wish to test the hardware via the cli, otherwise configure your software as required by your application.


#7

you are right, stopping my squeezeslave, the test with curl script is running well

otherwise, i am still having some trouble using phdac with squeezeslave. The sound is pretty bad.
But the point is phdac is well integrated into my pizerro

Thanks a lot


#8

my thought on quality is that it might have to do with the output volume. Try to see if it can be adjusted with the alsamixer?


#9

Ignore the above, I thought there was a layer in software that could affect output volume, but there isn’t.

… how are you connecting it to the amp? and is there a difference in quality when playing back through speaker-test/aplay from the cli and a stream via sqeezeslave?


#10

I have just tried another squeeze client, squeezelite, and it works fine, sound is quite good

thanks again for your concern