Motioneyesos suction camera holder


#140

That confuses a lot of people, me included when I started using my first Raspberry Pi. I still find myself double checking hookups before powering up. At least no harm was done. I have a nice carboard card with it all marked on it I got with some stuff I ordered from CanaKit a while back. I keep that Handy. Plus a link to the pinout page I posted above.


#141

I also have a small cardboard card with the same I should say, just GPIO pins only and no actual physical pin numbers.

I have it running in a shell now, and have edited out the Print nobody there line, because, very often, there wouldn’t be in this room. I’ll make a suitable box for it and find a more suitable place to put it.

This is probably the 3rd project I have done with the same idea of taking pictures.


#142

I usually use crontab to run stuff like that automatically on boot up.
run sudo crontab -e
add
@reboot python3 /home/pi/(your python file).py &


#143

Ordered the Robo Bit ultrasonic sensor last night. Should ship some time today. I’ll get it in about 10 days or so. Usually 11 or 12 days. Ordered a Time of flight sensor too. The breakout garden one. I’ll test it maybe with a camera but ultimately its going to an Arduino rover project I’m working on. I’ll test the ultrasonic sensor with a camera too, but its also going to be used in a rover project in the end. Thats the plan anyway, once I sort out what the extra add on board does, and what the actual sensor model number is.


#144

Ok, good stuff.
Blimey 10 -12 days for shipping!, but it’s not as bad as 15 -20 days when I buy stuff from China, lol.

Just out of interest, what is the difference between the Robo Bit ultrasonic sensor and the bog standqard HC-SR04 sensor, apart from the physical side. They are both sensors, but what else.

Jus for information, I started the python script at about 11pm last night, and left it running untill around 08.30 am, and in that time it produced just over 4000 pictures!!. When I looked at them, most were of virtually nothing.


#145

It’s that long because I take the snail mail I’m cheap option. ;) It’s only 10 bucks for the shipping, plus I’m on the other side of the big pond.
I’ll let you know what the difference is when I get it. One thing is it has that extra board on it to make it easy to mount to the Robo Bit Rover. And that extra board has some components on it. Best guess is its a 5V or 6V to 3V regulator. If need be I can remove that and bypass it and still use the extra board. Or just take the extra board off. I’m just flipping the coin as it saves me ordering it from someplace else and paying a second shipping charge. And that extra board may make it easy to mount it to a servo for side to side scanning.
I have umpteen Raspberry Pi’s that use 3.3V logic, two Micro Bits that use 3V logic, an Arduino that uses 5V logic, and an Arduino that uses 3.3V logic. Should be no problem finding at least one device its compatible with.


#146

Yes, I usually go for the cheapest option, like free if I can get it, for shipping / posting goods out to me.

You probably have as many pi’s and arduino’s as I do, lol . I have 1 pi3 something, 3 pi zero’s, with only 1 in use as a music server, then I have 2 nano’s with 1 in use, then 10 arduinos, with just 7 in use. And as far as I am aware they are all 5v, but the good thing about the arduinos, they can take upto 12v. That is not recommended tho’ and I generally use between 7v and 9v dependant on it’s use.


#147

I just magnified / blew up the picture, its an HC-SR04.
The Arduino’s can take up to +12V Vin supply voltage, its regulated back down to +5V.
For the UNO anyway. You still can’t exceed +5V on the logic pins though or you will damage it.
I have a MKR 1000 wifi, its 3V logic, even 5V on any of the input logic pins will damage it

Two 3B+'s, two 3B’s, a 3A+, two A+'s and a dozen plus Zero W’s
My project / build pictures are here, https://1drv.ms/f/s!AjOYwiwlwDtpgUMsp2qnevKpGEHb
Might have already posted that, getting to be a long thread and to lazy to go double check, lol.


#148

Some interesting pictures there, and I like the breaboard frame. It looks like a miniture bed made from meccano. This is what I used to play with when I was a kid at home.

It was on the Arduino forum thart I was told about what voltage you can supply to the UNO, and have stuck with either 9v or 7v since then.

My last working project I used a nano which is 5v, but as the breadboard was a double lenght one all the parts were fitted on it.These are the nano, HC-SR04, LCD screen 16 by 2, and a couple of buttons/switches. Initially I used 5v from my PC to power it up. Then I found that lcd screen wouldn’t even light up, and I messaged the author, and he told me to use a 9v battery, which was part of the project anyway. So that’s what I use now, a rechargeable one rather than an alkaline battery.


#149

Its called open beam, I think min is 20mm, or maybe its 15mm? I’d have to go measure it to confirm that. I haven’t bought any parts for it in a long while. Adafruit stopped selling it after I bought my kit.

I’m currently using the USB port to power my UNO. I will be buying a 9V barrel connector power supply from Adafruit at some point. I have a 16 x 2 LCD screen on my UNO. Its working just fine powered by the 5V via the USB port.
I think you can go as high as 20V in but the 5V regulator will work hard and get hot with anything over 12V. Which is why they recommend 7 to 12 V if you use the barrel jack power in or the Vin pin. .


#150

Yes, that is what I use, barrel jacks, and that is where the 9v or 7v goes in.
I have a couple of 9v battery holers with a switch and a barrel jack, and they are just the job as it is fairly small and portable of course.

I tend to think that it was because of the added HC-SR04 sensor that maybe put an extra load on the 5v from the usb port, because otherwise the lcd screen does light up.


#151

Yeah, stock USB 2 ports are limited to 500ma. Thats not all that much these days. And some tablets etc won’t do the full 500ma.
I have a 9V battery I can use if need be. It plugs into the breadboard, not the barrel jack. I had it ready if need be but didn’t have to resort to plugging it in.
I have a GPS breakout wired up that I got working. I could see the GPS data over a serial connection. And the 16 x 2 display working. The plan was to display the GPS data on the display but I never got that far. I had some family matters come up that needed my attention so it got put on the back burner for a while.

EDIT: Anyway, just got confirmation that my order shipped. So its hurry up and wait time, lol.


#152

Oh I also have an accelerometer on the said board! I have fastend the LCD screen under the top of the box I have it in. This is to make easy to read the figures on the screen.


#153

After another night of about 3000 pictures taken of nothing moving, I have gone back to motioneye for now.
I wasn’t really happy with motioneye because both my usb and pi camera were dropping out, ie no picture from either, and it got fairly often as well. I posted the problem on the motion group and was told to drop the resolution of the cameras.
So now I’m going to check or see how it goes with lower resolutions.


#154

I run mine at 1280 x 720. The spec for the Pi camera says it supports 1080P @ 30FPS and 720P @ 60FPS. At 1280 x 720 my video is pretty good. Just a little lag now and then. Its usually around 20+ FPS.

I haven’t had a camera issue in a while now, knock on wood. Now that I fixed that one iffy camera its pretty reliable. Most of mine I shut down at night. I only have one I leave running 24/7. It’s a 3B+ and V2 camera. I have motion disabled though. I just monitor them via the web interface and take the occasional video manually.


#155

Yes, I have my Pi camera at 1024x768, but the usb camerqa is at 320x240, and I must admit that it is a good picture. Anyways I’ll see how they go and adjust as required.


#156

Tried to update my cameras via the web GUI update option today. 3 of the 4 failed and then would not connect to my network. Ended up reimaging and setting them all back up from scratch. Used the new image and all is fine now.

My ultrasonic distance sensor arrived Friday. I haven’t done anything with it yet other than remove the extra circuit board. There were no extra components on it, like in the picture, just straight wiring from the large mounting holes to the pins on the module. I put a male header on it so I can plug it into a solderless bread board. Near as I can tell its just a regular HC-SR04. Going to try and play with it in the next couple of days.


#157

Yes, the HC-SR04 is dead easy to get it working , but the lcd screen needs a 10k pot to set the contrast, which is the main thing. Once that is done, bingo, you’re away.
I did a check of the distances with my sensor, and while not exact, it is fairly close with the measurments. On a measured distance of 44.5 inches, the sensor reads 44 inches. With a measured distance of 5 inches and 13 cms, the sensor reads 5inches and 13cms as nears as.


#158

You can use a resistor in place of the pot. I have a pot wired up to mine at the moment. I had one on hand so why not use it. I’m probably not going to bother hooking the ultrasonic sensor up to trigger a camera. Still mulling that over. I can do it if you want, but I’m leaning more towards just hooking it up to my Arduino. The GPIO is not easily accessible on my Motion Eye Pi’s. And I now have really short ribbon cables on the cameras that were a PITA to attach with the Pi in the PIBOW cases, lol. It looks really nice and compact, just a pain to plug the cable in and get it locked. I think they were 5cm long or something?


#159

I have 1 k resistor connected to the contrast wire on one of my projects, and have just tried the same on another just now.
I just use my sensor to measure distance, and yes I have used a 5mtr tape measure before, it’s just that I thought that the distance sensor would be easier.