My new XIAO SAMD21 enumerates as Seeed femto M0

Hi there, I’m a noob with these particulart devices and stuck at the first hurdle.
I have a cunning plan for a lovely design and a big pile of components and I have bought 5 delightful little XIAO SAMD21 modules from Pimoroni.
I have used many arduino-compatible boards of many different types in the past, so I’m broadly familiar with the procedures for running stuff up in the IDE.
Following the instructions on the XIAO s/w page I installed the json link into the arduino preferences box and now the various seeed boards appear in the list correctly, including the Seeeduino XIAO.

However when the module (type “Seeed Studio XIAO SAMD21 no.102010328”) is connected to my PC, it enumerates in device manager as “Seeed femto M0” and then it can’t find the driver.
… And because it can’t find the driver, it doesn’t give it a port in the arduino IDE and so I can’t connect to it in any way.

I tried following the instructions that I could find regarding drivers and Seeed modules and windows 7 (64 bit) which I’m on, but none work or apply fully.
Is it normal for these devices to enumerate as ‘femto M0’ devices ?
I may have done something incorrect but am concerned that the boards enumerate as a different type to that which I bought.

Any hints to resolving this or pointers to the exact instructions for installing correct drivers would be greatly appreciated.
Best regards.

Have you seen this?
Getting Started with Seeed Studio XIAO SAMD21 - Seeed Wiki

1 Like

I’m embarassed to say that the “pressing-reset-twice” thing fixed it.

It didn’t occur to me to try that on brand new boards.
It was very silly of me.

It’s working now. I am finding that it seems to need that for every new sketch download…
I think I’ll wire a button onto the contacts.
Thank you again… my cunning plan may now continue!

I have reset buttons wired up to my Pico’s. Saves a lot of hassle, no having to unplug and plug back in etc. Good to hear you figured out what to do.