Pi Zero W, Pirate Radio and the PhatBeat

Volumio is configured quite differently from Raspbian, and you shouldn’t attempt to make any changes directly to it via SSH. Everything will crash and burn. We deliberately block our installers from running on any untested OS for this reason- they’ll only get you into trouble!

That said, I’ve been working with the Volumio team to get our boards supported, but we’re limited by their release cycle and the constraints of the OS.

For the time being you can get sound running just by configuring it through the Volumio UI as having a hifiberry DAC. Our own board definitions for Volumio are just clones of this config option, anyway.


This is a little trickier, and we’ve no idea when Volumio- or any other distribution for that matter- will release a compatible version. Right now they will have been caught off guard.

You can get the Zero W WiFi running manually, but it’s not a task for the faint of heart. That said, if it’s a fresh image it doesn’t matter if you make a hash of it- you can just try, try again!

I haven’t tested this on Volumio yet, but it worked on ResinOS.

You’ll need a set up Pi or Linux computer to perform surgery from, and then you’ll need to:

git clone --depth=1 https://github.com/raspberrypi/firmware

This local copy should have a boot folder and a modules folder in it. You want to replace your Volumio /boot with the contents of this newly downloaded boot folder and you will also need to copy over the two folders from modules into /lib/modules on Volumio’s root filesystem.

Finally you’ll need to grab (not sure if this step is 100% required yet) the firmware files from: https://github.com/RPi-Distro/firmware-nonfree/tree/master/brcm80211/brcm

Specifically you need brcmfmac43143-sdio.bin and brcmfmac43430-sdio.txt which must go into the /lib/firmware/brcm/ folder.

VU Meter

This is rather trickier to get working, and more difficult to push up into Volumio but I’m working on it. I have some now outdated instructions that I need to update. They violate the “don’t modify anything over SSH” rule, though.

Came here with the same issues - Kinda glad it’s not just me.

Thought I was going to have it all working in my lunch hour, but sadly failed.

Look forward to getting it working at some point.

1 Like

We’re working on our own setup script to create a VLC-backed radio with everything working in the interim. It wont be nearly as glossy as Volumio or any of the other similar distributions out there, but it will work.

You might want to look into shairport-sync too- there may be an update to our airdac install script soon to support pHAT BEAT.

Thanks for the quick reply, in a way I’m pleased I’m not the only one suffering.

I don’t really care how pretty it looks, my goal for this is something I can switch on, pick a radio station and let it play. I’d hope it’ll start quickly and work via wireless.

I’ve written a fresh Volumio image and am just trying to get into it from the initial boot. The whole thing seems dreadfully slow and even making a simple change to the audio output settings took about twenty minutes with multiple reboots. The only sounds I’ve had out of it so far are crackles and the startup sound.

1 Like

Please have a look at the open source Openhome Player. It is great me thinks


Indeed, Volumio is far from the only choice, there’s also;

And probably a bunch of other options I haven’t heard of.

Of course everything will have trouble with the Zero W except vanilla Raspbian at the moment, there’s nothing we could do or could have done about that. However, some might trivially be fixed with a “sudo apt-get update && sudo apt-get upgrade”- this unfortunately doesn’t work on Volumio.

1 Like

The issues with speed are simply limitations of the CPU speed on a Pi Zero.

Have a shot with Raspbian and run our one-line-installer for pHAT BEAT, by opening a terminal and typing curl -sS get.pimoroni.com/phatbeat | bash, then try some playlists on YouTube, in the meantime.

1 Like

I’ve just chucked one of my standard vanilla Raspbian built cards in, all fully up to date a couple of weeks ago and there’s no WiFi. Just running an update in the hope that the WiFi will appear.

Yes there are many options!

Don’t know about the others, but Openhome player installs on top of standard raspbian, so should work great on Zero W.

It is upnp so can be controlled from any control point app eg Bubble DS.

There is even a upnp control point stack in python among other languages that goes great with it, and all other upnp players, to make control apps.

You’ll need to use the most up-to-date version of Raspbian, just newly available, or else the Wi-Fi won’t work due to kernel changes.

I’ve got I playing my favourite online radio station (Kool London, in case you’re interested) on my old first gen Pi Zero, with a WiFi dongle.

If I can install Raspbian on my Zero W, use the one line installer and run some software that will allow me to choose between a bunch of online radio streams using the GPIO FWD/REV buttons and allow play/stop and vol up/down, I’d be an incredibly happy camper (as I want the VU meters too). ;)

Any suggestions for that use case please?



If you want to roll a vanilla Raspbian (freshly downloaded from , not an old image since the image was not updated until hours before the Zero W was launched) and try out my current VLC setup, it’s working quite nicely: https://gist.github.com/Gadgetoid/47d8f873fde39fcbe83e6dab0e855f72

This is the true “hackers” setup, though. But also serves up the VLC web interface and is compatible with some apps on iOS/Android for remote control.

Change playlist.m3u to include your own stations ;)

1 Like

Updating my vanilla image worked so I’ve got wifi now, that’s good.
Running the install script for the phatbeat ended like this:

checking for wiringPiSetup in -lwiringPi... no
configure: error: You need libwiringPi installed

Installing Pi VU Meter...
make: *** No rule to make target 'install'.  Stop.

I’ve rebooted now, how can I actually test this to see if I get any sound please?

I can confirm that Mopidy, Mopidy-Spotify, and the Iris front-end work beautifully!!

I followed the instructions here: https://docs.mopidy.com/en/latest/installation/debian/#debian-install, and here: https://github.com/jaedb/iris

But I’ll put together a proper tutorial ASAP!

1 Like

Excellent, trying those steps now. Let’s get this working :)

Damn, it’s bombing out with a failure to find wiringPi. Presumably you’re running Jessie Lite? I’d run into the same thing, but only just noticed the VU Meter install had failed. Odd, because it should install it if it’s not there.

You can fix by running sudo apt-get install wiringpi and running the setup again.

Absolutely perfect!!!

Took an age to run all the scripts, but this is EXACTLY what I was after, thank you so much!

Drat you got the upside-down VU meter before I patched it :D But otherwise; awesome!

Haha was going to ask about that ;)

Will it be easy to change?

Looking good, despite the upside down meter!
I’m actually starting again - Any hints as to exactly what I need to run?

Sorry, I’m not having a good day.