Piano Hat for headless pi running Fluidsynth

I’m trying to setup a headless Raspberry Pi running Fluidsynth using the Piano Hat as the MIDI input. So far all of the examples work (I’m especially fond of the 8-bit synth) except for midi-piano. When I run it I get the following:

This script requires the midi module
Install with: sudo pip install midi

Following those directions results in:

sudo pip install midi
Looking in indexes: Simple index, piwheels - Simple index
ERROR: Could not find a version that satisfies the requirement midi
ERROR: No matching distribution found for midi

Does anyone know where that module is? It’s such a common term I can’t find it myself.
Or, does anyone happen to know if I can’t actually use the Piano Hat that way?

Thanks.

Try
sudo pip3 install midi
It may be a Python version issue. Bullseye only has Python 3 installed.

No such luck. It still just returns the same errors.

I was able to find a module called python3-mido which looked related, but installing it and running midi-piano as python3 didn’t seem to work either.

Ok, that sucks. My Piano Hat is setup as an itty bitty beat box with a Drum Hat. Buster I think? It’s not Bullseye that’s for sure, might even be Jessie.
The only example I ran was the simple-piano.py as that’s the one used for the beat box setup.

I can get the local piano to work, as well as the 8-bit synth. Only the midi piano isn’t working.

Edit: Something I forgot. I tried following the Readme.md in the files but doing that not only doesn’t make midi-piano work, but after everything else stops working.