Picade 10" Pi4 No signal [SOLVED]

So I recently picked up a 10" Picade however, I have been having problems with the display. I uncommented the “hdmi_force_hotplug=1” line in the /boot/config.txt file and I still get “No Signal”.

For a few hours yesterday it was working (with constant screen flickering) not sure what made it work just started working.

However, today I moved the USB plug to a different port so I could plug my keyboard in and now I get “No signal” I tried all USB ports and restarting and none of them are working. I tried several different Raspberry Pi power supplies and that doesn’t do anything either. I restarted dozens of times on different ports and nothing.

I moved the SD card to another Rpi 4 and it boots up on that just fine.

Currently on: Retropie 4.7.1 (Linux 5.4.79-v7l+ armv7l GNU/Linux)

From my research it seems like uncommenting the hotplug is the only offered solution…is there anything else I can try? Is there a way to determine if its the hardware?

edit: I found a working solution. uncommenting the following line in /boot/config.txt: “config_hdmi_boost=4”