Pirate Audio Headphone Amp Mopidy installation failure

Hi there. I have been having problems with installing Mopidy as per the directions on pirate audio amp page. I am installing it on Raspberry Pi Zero with Raspbian Buster Lite installed. It’s fully updated and upgraded.
Please see the attached images of screenshots taken once the installation supposedly finishes. The LCD doesn’t display anything except for the backlight. Presumably, because the Mopidy doesn’t install and start properly.
The errors are about missing files and directories that the install.sh script should have installed.
Many thanks for all the help.

![IMG_20200120_230208|655x500]

I have the same issue. Can anyone help?

This is what worked for me https://forums.pimoroni.com/t/pirate-audio-3w-stereo-amp-for-raspberry-pi/12710/2?u=inky_72

Thanks Inky_72.
I have seen that post. I will wait for a few days to see if they come up with a solution for the Iris to go with Mopidy 3.x

hi
have you tryed a copy of stretch i think that was the copy around when the headphone amp was made

good luck

Sandy’s written a script that should help with this, if you run the following command in a terminal you should end up with a working installation:

curl https://gist.githubusercontent.com/sandyjmacdonald/b72b65d827d85166b4739e12867d9e1b/raw | sudo bash

If you want to see the script before running it you can view it here: https://gist.github.com/sandyjmacdonald/b72b65d827d85166b4739e12867d9e1b/

It installs a development version of Iris I believe, so please be aware of that.

1 Like

Hurrah…IT WORKED FINALLY! After 2 months, it did!
Thanks a lot Matt.
The Iris web page says to upgrade to 3.44.0
Should I do that or not?

Just googled it and found this: https://github.com/jaedb/Iris/issues/489

So if it’s all working probably best to leave it for now and see what happens with that bug.

1 Like

Make sense. Thanks once again!!!