Pirate Radio one line installer fails - repository not signed

Hi guys,
First post here. I just had to do a reinstall of my recently bought Pirate Radio kit. For some reason the thing just stopped working altogether, no reboots worked, no pressing the buttons on the side, no server connections, ssh, webinterface nothing.
So i tried to do another clean install using the one-line installer:

Which gave me an error saying:

Updating apt indexes...
......W: GPG error: https://apt.mopidy.com buster InRelease: The following sign not available: NO_PUBKEY 78FD980E271D2943
E: The repository 'https://apt.mopidy.com buster InRelease' is not signed.
Apt failed to update indexes!

And then the installer quits on me.
Of course i tried googling things but as I’m not really a linux user i can only go so far with copy-pasting from sources claiming a solution to similar problems as apparently this problem itself is new.
Trying to apt-get update and apt-get upgrade both root did not solve my issues.
I then also tried to do:
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 78FD980E271D2943
But that did not solve my problem either.

As i said, not a linux user, just fiddling about. Could someone please help me out here?