Problem with Countdown Timer Cookbook


#1

Hi there - I just got Number and Light modules to add to my Kickstarter Large Starter Kit. The number module works fine when using Rockpool to show light readings, for example. But when I try the Countdown Timer cookbook http://flotil.la/cookbook/countdown/ I get gibberish on the number display. I have tried unpowering & repowering, still the same. My Dock firmware has been updated. Any ideas?


#2

Hey! I’ve just tried this myself, and can confirm that it is somewhat garbled! @gadgetoid is the man to investigate. Hopefully he’ll be able to squash the offending bug. :-)


#3

a wild gadgetoid appears

Yeah, it really is borked. Looks like the command-order and byte sequence for the letters has gone awry, but I’m at a total loss as to where and how. It’s a regular ol’ mystery.

I’m looking into it!


#4

Fixed! You should shift+refresh to get the latest cookbook.js. Looks like I’d added some chars into the character map for display on number, but not changed the offset in cookbook.js which provides wrappers for Flotilla modules.


#5

Thank’ee sirs! Happy to know I don’t have a faulty display :)