Raspberry Pi Zero - Minecraft Pi Crashing


#1

Just received a raspberry pi zero today along with adaptors and have been very pleased with it, however I noticed while using it and testing things that the Minecraft pi edition had a couple issues which I haven’t found anywhere else. I was using the newest version of raspbian from the site (as of 15/02/18) which I’d installed and used on an SD card on a model b+ with no problems, so I took it and put it in the zero. Everything worked normally till I opened Minecraft, when it created a world, loaded it but then froze entirely. Couldn’t get it to unfreeze so pulled the power. From then on it would open the game and crash a few seconds after loading a world. I reinstalled a new version of raspbian and have tried an older one too but same issue both times. I’ve tried running it through the terminal and once or twice it has just crashed entirely, but I also get:

XI0: fatal IO error 105 (No buffer space available) on X servers “:0.0” after 6256 requests (6256 known processes) with 1 events remaining.

I’m somewhat new to the pi scene and don’t really know what this means and can’t find any sources mentioning it, so anybody know what exactly this is and if there’s any way to fix it?


#2

Minecraft is an extremely resource-intensive application, I would expect it to be problematic on the Pi Zero. Bear in mind it’s also abandonware and hasn’t had a bug fix or update since its release.


#3

Yeah, eventually gave up and got a zero w for this purpose and used the zero for a usb project, just a random bug I guess :/