[Solved] Hyperpixel and Stretch


#1

Is working with Raspbian Stretch on Graphical mode?
Because I can’t make the screen shows anything under Raspbian completely update on Graphic mode with my RPi3 but I can run on CLI with latest Raspbian on a RPi A+
In both cases the script don’t finish and I need to complete the installation manually.
Thanks in advance.


#2

Is mandatory to use Legacy video driver and disable OpenGL.
Maybe this must be added in the Readme on GitHub.


#3

Have you tried “GL (Fake KMS) Desktop Driver”? I found a thread that suggests it might work with DPI, but I’m not sure.

I will update GitHub accordingly.


#4

Not, not tried but I think for me is enough with Legacy. But maybe I give a try to Fake KMS, only for have the complete picture. I’m going to prepare a short review for my blog and maybe the content (translated can be used to improve the GitHub page) .
Regards.


#5

Tried. And is working prefectly, thanks!

In short, use one of these options in

sudo raspi-config > Advanced Options > GL Driver and chose option G2 or G3:

  • G2 GL (Fake KMS) OpenGL desktop driver with full KMS
  • G3 Legacy Original non-GL desktop driver