Sound sync issue with Mame4all


#1

Hi. New to this forum and Picade / Raspberry Pi in general. Having built the Picade with a Pi 3 model B, I have been trying to get Mame4all up and running. In the main this seems to work well, except for a strange sound issue with syncing to the video output. When a game is first launched, the sound seems to be playing at the right time. However, after just a few minutes it becomes apparent that the sound has now drifted and happens a second or two after the graphic movement. E.G. in Pacman, press the coin insert and you’ll hear the squelch sound a second or two after the ‘Press Start’ message appears. If you restart the emulator it is back in sync and plays at the same time as the writing appearing. Seems to happen on all games, Frogger for example, you will hear the jump sound after a short delay and not synced (though initially it is, a few minutes on it’s not).

I know about the RetroArch video controls and getting the frame rate matching, etc. but that seems to make absolutely no change to this problem whatsoever. I am using the recommended software image from Retropie.

I’ve tried setting the screen resolution to 60Hz, as well as 70Hz. This is using the 12" recommended screen (which I had to source seperately). Nothing makes a difference.

Does anybody else have this issue and is there a solution to it? It really is spoiling the gameplay when all the sounds drift, delayed, after running the emulator for a couple of minutes…

I have not yet tried any other emulators but would really like to get this resolved first.

Many thanks.