Speaker pHAT LEDs on updated/upgraded Nov 2016 Jessie Lite


#1

Hi, I’m having trouble getting the VU LEDs to work on my Raspbian Jessie Lite.

A few things out of the way:

  • It all works fine (inc. VU LEDs) on a freshly downloaded copy of Jessie Lite once I do the CURL install and play an .mp3 via mpg123.

  • So it’s my customised copy of Jessie Lite… somewhere. I’m really, really reticent to scrap this and use a vanilla copy, since I’ll have to set up my SSH keys, my user account, my bash profile, my blah blah blah. I appreciate this is a PITA. My /boot/issue.txt says Nov 2016.

  • Audio works fine with mpg123

  • I’ve done a full apt update && apt -y upgrade both before and after the CURL install (obviously there was nothing to upgrade the second time, but just in case)

  • I’ve copied over the /boot/config.txt and /boot/cmdline.txt from the vanilla JLite where everything works. Diff confirms this. So it isn’t config.txt nor cmdline.txt .

  • I’m using a Pi Zero (not W).

  • I usually run from inside a GNU Screen session over SSH

One thing that sticks out as a possibility, is that user aoakley as the only user, and /home/aoakley the only home directory. This was renamed from the default pi user many moons ago. So if the CURL script is expecting the user to be pi… well there’s my problem. If so, what do I need to run to enable the LEDs for user aoakley please?

Any suggestions for anything to try, very much appreciated. I realise that Pimoroni’s developers would be perfectly within their rights to say “it works with the vanilla Jessie Lite so it isn’t our problem.” I’m moderately competent on the command line and have got backups, so I’m keen to try any suggestions.

Thanks,


#2

try adding your custom user to the i2c group, like so:

sudo adduser aoakley i2c

#3

Good call, but sadly aoakley is already a member of i2c:

$ groups aoakley
aoakley : aoakley adm tty dialout cdrom sudo audio video plugdev
games users input netdev spi i2c gpio

Any other guesses, very much appreciated.


#4

We pushed updated configs earlier today that fixed similar symptoms for espeak, so perhaps re-run the speakerphat installer and see if that magically cures the problem for you too.

Besides that, I’m afraid that if you don’t receive any particular error/log related to the problem I wouldn’t know where to start troubleshooting :/