Automation HAT does not connect with RaspberryPi

Dear Community,

I have problem with my Automation-HAT. It does not connect with my RaspberryPi although the HAT is mounted properly on Pi and the software is installed like the instruction said.
When I run the example scripts, I get an error message that says: “No ADC detected, check your connections”
In Node-Red the status switches from “disconnected” to “connected” every few seconds but most of the time it remains disconnected…

Does anybody know what the problem could be?

Thank you very much!

Ok I fixed it by myself.
So if anybody encounters the same problem and tripplechecked all other possibilities.
The solution is to completly reset the RaspberryPi and install the OS from the ground.
Then just follow the instructions on the website.

Now it works totally fine!

Had the same issue. Got it also working, but only certain commands are working. Could you assist switching lights on and off? Seem to either get errors or nothing working.