Blinkt: Having To Run Scripts Twice


#1

I’m pretty sure that this is down to me but I’m having to run scripts twice to get the Blinkt LEDs to react.

I’m seeing this with both node-blinks and the Pimoroni example scripts such as rgb.py.

So, for example, if I run pgb.py with something like ‘sudo ./rgb.py 255 0 0’ I don’t see the LEDs change to red until I run the script a second time (and if I change the colours in that second invocation I don’t see them until I run the script a third time, etc.).

Essentially it feels like the Blinkt is receiving the colour change details but isn’t actually updating itself until more commands are sent to it.

Does anyone have any idea what I might have done?


#2

A bit of a late reply to my own post but, very possibly due to a software update at some point, my Blinkt and scripts are now all working as expected. I recently decided to tinker again and just wanted to mention it in case anyone else is or was having this problem.


#3

Yep, this was a problem with clocking out extra data, and differences in behaviour between two variants of the APA102 LEDs used on Blinkt! and Mote. We’ve fixed the issue in software now though. More details at the link below.


#4

Wonderful, thanks Sandy. For a while I thought it was just me being stupid but then saw that someone had the same problem with the node-blinkt Node library (https://github.com/Irrelon/node-blinkt/issues/1).

A code change to fix the issue has now been merged into the node-blinkt project.

A second Node implementation for Blinkt!, blinktjs (https://github.com/pinkkis/blinktjs), already implemented the fix and should work for those of you wanting an ES6 implementation.