Fan Shim Not Turning On

Hi all,
I just received a Pi 4 - 4gb with a fan shim and have everything up and running like a boss, but the fan shim will not stay running for anything, it’ll work fine for a bit then just stop and won’t engage again. I’ve set the on threshold extremely low (40) to kick off at (20) to see if it’ll run continually, but it won’t stay running. There is a small case fan as well but I have it ran off of pins that the fan shim doesn’t touch to avoid conflict. Do I have a defective unit, or how would I go about uninstalling the fan shim so it’ll just stay running continually? I don’t really care about the led lights showing me temperature range, I just want it running to keep it cool.

Are you monitoring your temperature?
Is the SOC actually getting hot enough to turn on the fan shim?
I would unplug the second fan, while testing the Fan Shim.

From terminal run
cat /sys/class/thermal/thermal_zone0/temp

Or add the “CPU Temperature” panel applet to the task bar on the Raspbian desktop.

Perhaps the simplest solution, if you want to run the fan shim continuously, then don’t install the fan shim software.
By default it runs all the time and needs the software to turn it off.

Yep I’ve watched the temp from the pihole and reduced the temp that it should kick in at and still nothing. I’ve unplugged the second fan and tried the same and still no go.

I’ve tried uninstalling the fan shim software but can’t figure it out and I really don’t want to wipe the whole sd card and spend half a day getting everything back installed.

I’d reinstall the fan shim software, and go with the default values when installing the daemon…

I found the uninstall script, ran that, rebooted, reinstalled fan shim software, reboot. Still no go. I went nuclear and wiped the sd card, fan shim didnt run by default. Installed the fan shim software and it decided to work now. Super strange. Now I have to reinstall everything else and hope the fan stays working.

Yeah, that sucks. Been there done that myself from time to time.

Backup image is secured and stored on my NAS haha