Fan Shim on Pi4B no LED, not stopping

Hi all!

I have a Pi 4B with 4GB and installed the script as described. The script also is installed properly (service runs), I also can change the settings, but the LED doesn’t work (not red, not green). When I boot up the fans runs and does never stop. When I move pin 12 the fan stops, when i release it, it starts again (but still no LED). The button has no function either.

I had installed the fan earlier on another Pi 4B 4GB, it started and stopped automatically as expeted, but the led also did not show up.

What’s wrong here?

When at least the fan worked properly (without LED) Noobs 3.2.1 (Buster with Desktop) was installed, including all updates.
Now I use Noobs 3.3 (Buster with desktop), the script is running but the fan does not stop, also the LED is off.

What can I do? I can follow instructions, can open files with “nano” but don’t know how to program.

ATM only pi-hole with unbound is running on my Pi (at least this works well).

Thanks in advance.

It’s likely not making contact with all the GPIO pins it needs to work. I have one that was that way. I fiddled with it moving it, tilting it a bit, even plugged a female header in on top of it. I couldn’t get it to work. Pimoroni sent me a replacement and that one worked fine on that same Pi 4B.
The one I couldn’t get working I soldered to a female header. Now it works. It sits higher up and away from the Pi’s SOC but it still cools it down adequately. I’m using it with a Pi 3B+ at the moment.
You can contact Pimoroni via e-mail via the following link

The only other thing you might try is ditch NOOBS and go with just installing Raspbian

I installed Raspbian now. It also didn’t work. I bent the pin 12 afterwrds and the Shim Fan starts and stops as expected, but the led is still off. :-(

GPIO 14 (pin 8) and GPIO 15 (pin 10) are used for the LED.

Thanks for your quick reply, but I cannot bend them all. Is it a known production failure?

It’s the second Shim Fan I tried now within the last two weeks.

I don’t know if its a production issue? I have 3 Fan Shims, 2 worked with no issues and one was a PITA to get working.
If the Utility Hat ever gets released I’ll switch to it when possible. It will have an actual female header instead of this friction fit “shim” stuff.

EDIT: The Fan Shim I had that was problematic like yours, Pimoroni replaced for me after I used the contact us link and e-mailed them.

Are you seeing anything on your LED? It’s possible that you have UART enabled ( enable_uart=1 in your /boot/config.txt ) but IIRC this shouldn’t necessarily stop the LED from working.

Make sure your Fan SHIM is also making good contact with the GPIO pins, you might have to give it a little wiggle since the friction-fit header isn’t perfect. Run python in the examples folder while you do this, it may suddenly burst into life.