ImportError: No module named bme280

Fresh install of the latest PiOS on a Pi Zero W.
pHat Stack with Breakout Garden Mini i2c SPI and Mini i2c
BME280, RV3028, LTR-599 in the mini i2c BG
0.96 SPI Color LCD in the mini i2c SPI BG

The BME280 is giving me the following error when I run the all-values.py file. Either from thoony or via command line.

from bme280 import BME280
ImportError: No module named bme280

i2c is enabled and I have run the following.
sudo pip install pimoroni-bme280 smbus
sudo pip3 install pimoroni-bme280 smbus
and also did the following
git clone https://github.com/pimoroni/bme280-python
cd bme280-python
sudo ./install.sh
and rebooted several times.
Tried two different BME280’s, one that was working before I reimaged my SD card, and one new one I just received today. Both give the above error.

@Matt

Looks like I got a messed up RV3028 RTC in that order. Battery was inserted reversed? Flipped it around the correct way but it still wouldn’t keep the correct time. Checked the battery and it was dead. I swapped a good one from a working RV3028 but it still won’t work? After swapping the battery back into the other working RV3028, and swapping it in place of the one that’s not working I have a working RTC so the software install was fine. BME280 still won’t work though?
The LTR-599 in the mini i2c BG worked OK.
As did the 0.96 SPI Color LCD in the i2c SPI mini BG.

I’m having the same problem. Raspberry pi 4, default raspberry pi os install. I get the bme280 module not found error. Otherwise, the lcd works and the light sensor works.

Try running this from terminal.
pip install pimoroni-bme280==0.0.2
It got mine working. It was posted to an issue I opened on this on GitHub.
The ==0.0.2 installs the older version 0.0.2. The newer 0.1.0 is the one with the issue.