Issues with Pi3 and Unicorn-Hat (8x8)


Hi, I need help with strange Unicorn-Hat behaviour on my PI3. After fresh install of latest Raspbian (kernel 4.9), running apt-get update & upgrade and installing Unicorn-Hat with help of Pimoroni Dashboard (getting latest rpi-ws281x (3.0.1) running demo scripts shows strange colors (they looks very brighter than before and they look very washed out - not as saturated as before. There is scripts that looks ok (like but there is many scripts that looks now very strange like or Then running a script makes my PI3 stops responding to other commands and sometimes makes my system read-only. It begins with some Raspian kernel update but it seems there is still a lots of problem even with latest Unicorn-Hat build. Any help or tips? Before I could run as example Homebridge server at the same time with Unicorn-Hat scripts using VNC as remote without any problems now I can’t even get Unicorn-Hat to work properly.


Ahoy! Could you possibly post a couple of photos of the demos running?


Hi Jon,
those pictures are from: random_blinky, cross and rainbow_blinky scripts. Most of scripts seems to show much brighter than before with very desaturated colors at the same time. I was testing this on two different PI3 with the same results and on both PI my system acts strange (locking, becomes read only) when running those scripts. I really love this unicorn-hat and I was using it every day but right now I can’t figure out what is happening so I hope for any help.

As a new user I can put only 1 image in a post :)




The washed out effect could be due to a mismatch between the rpi_ws281x and Unicorn HAT libraries causing there to be no gamma correction. You should try:

sudo pip install --upgrade unicornhat
sudo pip install --upgrade rpi_ws281x

And see if it helps.

Random lighting effects can be due to audio not being properly disabled. Make sure you don’t have dtparam=audio=on in /boot/config.txt

You can usually check if audio is enabled by running aplay -l.


Hi and thank you for replay

  1. I don’t have any random lightnings effects. The “only” visual problem is that colors are washed out and everything seems much brighter that usually even when changing brightness from 0.5 to 0.2 and yes I have tested both with audio forced to HDMI-only and with audio disabled with no success.

  2. I have already latest rpi_ws281x at version 3.0.1 so it dosen’t help

$ sudo pip install --upgrade unicornhat
Requirement already up-to-date: unicornhat in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: rpi-ws281x>=3.0.1 in /usr/local/lib/python2.7/dist-packages (from unicornhat)

$ sudo pip install --upgrade rpi_ws281x
Requirement already up-to-date: rpi_ws281x in /usr/local/lib/python2.7/dist-packages

3, My big problem is that every time running Unicorn-hat python scripts is locking my Rasbian or making it read-only. As long I don’t use Unicorn-hat scripts Rasbian works without any problems. I can also run others python scripts without any problems.


The locking/SD read-only issue should hopefully be fixed in rpi_ws281x 3.0.3 / unicornhat 2.2.3.

See: [SOLVED] Problems with Unicorn pHAT Software


I can confirm that after running: sudo pip install unicornhat --upgrade I got a brand new RPi-WS281-3.0.3 and new unicornhat- 2.2.3 and that solved all of my problems. Brightness looks right, color saturation (gamma correction) looks right, no more locks of Raspbian Stretch and so far no problems with sd-card become read-only. Thanks a lot for all help! and bringing my Unicorn HAT with my Raspberry back to life :)