Unicorn HAT - No Output


#1

Hi,

Just purchased a Unicorn Hat (and shiny new Pi 2) - the problem is with the Unicorn HAT.
Older Pi’s have been loaned away - but thought why should the kids have all the fun! So cannot try on a another/older model.

Tried both \curl -sS get.pimoroni.com/unicornhat | bash and a full git clone and install with a full re-image in-between.

Did not notice any specific issues in the output. Power supplies - tried two different “good” 5V/2A ones.

However any examples such as sudo python ./simple.py fail to produce any output on the LEDs - no error messages either,

Are there any other debug/commands I can try.
Am I missing something simple.

Thanks.


#2

I’ve been trying to get Unicorn hat running on RPi2. No luck. Works find with the RPi 1 B+
Something has changed… :(

The foundations forums are down again so a bit stuck.


#3

Same problem here :o(

Brand new RPi 2 and Unicorn HAT - no output at all


#4

The Pi 2 has changed significantly enough that the magical trickery used to make Unicorn HAT work has broken. We’re on it, don’t worry!


#5

Thanks for the update - I’ll stop going round in circles for now then.

Thanks.


#6

I was wondering if the I got an broken HAT or if it was just an incompatibility with the PI2. Thank you for confirming, I’ll stay tuned.


#7

Wish I had read the what works and what doesn’t with the Pi 2 before ordering mine with a Unicorn HAT :(. I hope it is all solvable in software otherwise I’ll be stuck with an unusable Unicorn.


#8

Don’t worry, it’s solvable. Getting it up and running has been one of my top priorities, since it’s something I can directly affect and don’t have to rely on anyone else to fix.

Unfortunately, between the lack of documentation and lack of understanding it’s proving to be somewhat tricky!

To top it all off, I had a dream last night that it was all fixed and working fine. Dream logic never works in reality :(


#9

Agreed! New Pi and HAT. Ah well. Will get there in the end.


#10

I too spent most of last night trying to figure out why my Unicorn HAT wasn’t lighting up (connected to my Pi 2). I thought it was something I’d overlooked.

I should have just come here first!

I’m hoping to knock up a sound/music visualiser program for it so really looking forward to the Pi 2 compatibility update!


#11

Me too (bought a new Pi2, Unicorn HAT and a diffusion layer for the Ninja PiBow case that doesn’t fit).
Glad to hear Pi2/Unicorn issue should be fixable.

I just want add my appreciation for anyone who is working on this issue. Thanks.

Craig


#12

Small update: Jon’s been tinkering with UnicornHAT this weekend, too, it’s definitely not a fatal hardware difference, but rather some new weirdness with memory caching. It’s so tantalisingly close to working that it’s driving us all completely bonkers!

We’re working on pinning down exactly what’s going on, so we can upstream a fix or work around it. Stay tuned!


#13

Best of luck. Keep us updated!


#14

Quiet in here. Heads down, working on that tricky Unicorn HAT!


#16

Just to tie up a potential loose end.
It looks like there has been some progress, a hacked version is available:
Link to Pimoroni Forum thread
Hopefully a fully finished and polished version will follow soon.

Thanks all!


#17

Just to chime in- we now consider this the “release” version, it’s available in pip

sudo pip install unicornhat --upgrade

And is pretty well tested now.

We’ve got some more changes coming to make it just a liiitttle bit better ( in terms of gamma correction ), but otherwise it’s case closed. Unicorn HAT is pooping rainbows like a champ again!

For anyone who’s curious, the code is based upon the rpi_ws281x, which Richard Hirst whipped up the Pi 2 fixes for- https://github.com/richardghirst/rpi_ws281x - he deserves praise and adoration!


#18

Richard Hirst - please accept our praise and adoration!
IoI .o. Iol .o. Iol .o. Iol .o. Iol .o. Iol .o. Iol


#19

I read that as “lol” first, then … I saw what you did there! Will never unsee.


#20

Marvellous!! Great work. Haven’t had to time to try it out yet but I’m looking forward to making myself blind :D


#21

Working well here… Ah my eyes !!!

Thanks!