Unicorn Hat HD not working


#1

Hey,
I got my unicorn hat hd yesterday, and tried setting it up, running the full install script curl https://get.pimoroni.com/unicornhathd | bash

I’ve tried this on two RPi3’s, with both latest Jessie and Jessie Lite, and i’ve not gotten any of the examples to work in python 2 or 3.

I’m suspecting the board is bust, but is there any other steps to check first?


#2

When you plug the HAT on your Pi, it should show a white gradient across the LEDs. If it doesn’t then it probably is sadly dead, and we’ll have to arrange a replacement to be sent.


#3

Nothing happens when it’s plugged in, I’m afraid.


#4

Don’t lose hope now, I’ll test against the latest Raspbian here and see if there’s something we’re missing.

What output - if any - do you see when you run the examples?

Edit: As in output in Terminal, not on the Unicorn HAT HD


#5

the normal text output of like “here’s 4 demoscene effects, press ctrl-c to exit” shows up in the console for them. No errors are shown. Same output happens if i try to run without the hat even plugged in.


#6

Fired one up on my fresh shiny new testing rig and it works fine, I’m going to have to concede that yours must be faulty :(

You seem to be using the right code and doing the right things, so sorry about that!

Could you PM me your order number, or drop us a support ticket with it so that we can arrange a return (we’d really like to know what went wrong with this one) and a replacement.

Cheers!


#7

Sent a support contact. Thanks for responding so quick!


#8

I have exactly the same problem with a new Unicorn HAT HD which arrived this morning. Was there any solution or was the unit dead?


#9

I have a pretty similar issue,

Pi3 + Unicorn HAT

I’ve run

curl -sS https://get.pimoroni.com/unicornhat | bash
cd ~/Pimoroni/unicornhat/examples/
sudo python ./simple.py

and nothing coming out the LEDs.

I’ve sent my details to customer support, but in the meantime (given it’s Saturday and my excitement of the visual delights is still high) was there anything that might bring this HAT to life? Is there anyway to check whether the HAT is plugged in OK, to run any diagnostics on it, or check whether the HAT has been picked up by the board? When I do these commands above without the HAT installed I don’t get any errors either so doesn’t look there is a check going on to verify whether it’s installed before proceeding with the example.

@pinkkis - Did you get a new board and did that work OK for you?


#10

@ianh you should run:

curl -sS https://get.pimoroni.com/unicornhathd | bash 

Unless you’re using an original Unicorn HAT. They’re both quite fundamentally different in how they work, and use different code examples/libraries, etc.

Sorry I didn’t catch this over the weekend!


#11

Excellent, glad it was user error. We can quietly forget that :) It works beautifully now, looks amazing - I’m hooked, now on with my little project on the pi …


#12

@ianh I got a new board and it worked perfectly on the first try. Sorry
this is a bit late to respond :)

Regards,
Kristian Koivisto-Kokko


#13

Hi Ian,

I am having a similar issue with the Unicorn Hat not lighting up at all. Even after all the installs, nothing works. Running simple.py doesn’t produce any results. Did you find out if there is a way to even check if the board is connected properly or if the Hat is even being recognized?

Thank you!