Unicorn Hat HD Not Responding


#1

Hello all,

I just got a Unicorn Hat HD over the weekend. It was taking the place of my Blinkt!. I popped it on, and powered the PI3 on and nothing happened, which was not that concerning as i had not executed any commands. I downloaded all of the directories and scripts and went to run one of the examples and nothing happened. no matter what i try, i cannot get any of the examples to light anything on the Unicorn Hat. Do you think i just got a bad board? I did put the Blinkt! back on the PI3 to make sure the GPIO did not get damaged swapping the boards out and it works just fine still. Any ideas?


#2

I would unplug the power

Unplug the HAT

Check connections to the GPIO

Refit HAT

Power back on

Make sure you have the UnicornHAT HAD library installed

Then try whatever code again.

Good luck

Scott


#3

thanks for the reply, that is pretty similar to the trouble shooting that i did last night.

unpluged the Blinkt! kit
Plugged in the Unicorn Hat HD
Powered on PI
installed UnicornHat HAD library
installed Unicorn Paint library
Deleted my crontab -e script to run the blink on reboot

rebooted/powered down
tried to execute multiple examples from the library
powered down again
unpluged and replugged in the HAT, making sure everything was very tight

Tried all of that again.
re installed my Blinkt! to make sure i did not mess up the pins in the process and it works great. So i got that going for me!
not a glimmer out of any of the LED from all that.


#4

I think that pretty much leaves you with no option but to contact Pimoroni support. I’m sure they’ll sort you out.

https://shop.pimoroni.com/pages/contact-us


#5

@topher_csr few things to try/check

  • Could there be any other code running on your Pi interfering with the pins UHHD needs?
  • Make sure you’re using the Unicorn HAT HD library and not the regular HAT/pHAT one

#6

I did have other code running, but i stopped everything in order to run the Unicorn Hat HD. would it be a good idea to delete any of the Blinkt! coding?


#7

It shouldn’t make a difference, unless it’s running.

What does your /boot/config.txt look like?


#8

not sure, i will have to check it out when i get home tonight.


#9

do you know how i could check to make sure that no other scripts are running that may interfere
?


#10

A good catch all is to run: sudo killall python before trying the Unicorn HAT HD script. Although you might have a script that respawns in the background.

You could try: ps aux | grep python to poke and pry for running Python scripts.


#11

Looks like @gadgetoid got you sorted on a support ticket, so I’ll close this thread. :-)


#12