Unicorn hat hd cant get the paint program to work


#1

Maybe I am stupid but try as I may following the online instructions I can not get Unicorn Paint to come up on the Pi3. Help please.


Unicorn Hat HD will not work for me on Jessie rpi3
#2

After running the Python file, you should be able to access it by opening your browser and navigating http://127.0.0.1:8000 on your Pi.


#3

Sorry still no joy, that connection is refused, my hat remains a virgin. More help would be appreciated.


#4

Curious! What are you seeing when you run the paint.py script?


#5

Seeing nothing on the screen when I run paint.py


#6

You should see something like:

* Running on http://0.0.0.0:8000/
* Restarting with reloader

If you navigate into unicorn-hat-hd/projects/unicornpaint and run ./paint.py


#7

yes i see that what next?


#8

Now opening a browser on your Pi and navigating to: http://127.0.0.1:8000 should work.

Otherwise you’ll need to figure out your Pi’s IP address and open a browser to http://<IP ADDRESS>:8000

You should see the Python script output something when you connect.


#9

got it working thanks. Hat not showing anything, plugged directly onto the gpio pins on the pi. Sorry for the questions but what to do to get it lighting up. Thanks


#10

Hi Thanks for the help ss far but try as I may I can not get the hat to light up. All the software and dependency are installed. Trying to run examples from the unicornhat dir eg…sudo python demo.py and not a blink from the hat. Do I have a faulty unit? HELP


#11

Post a picture of your soldering - that’s usually the first stage people go wrong 🙂