2nd Unicorn Hat HD not working

I really want the Unicorn Hat HD to work but I am on my second HD now. I’ve confirmed that the HD is connected properly to the RPi3 B and I am running from a fresh install of NOOBS (I’ve tried a fresh install twice). ps aux | grep python shows nothing else running. A Sense Hat that I have works fine on the same RPi3 B.

No lights on startup and none of the examples work. Is there anything else I can try before trying to replace/refund again?

Thank you.

I don’t believe it lights up on startup like the Sense Hat does. I haven’t powered up my Unicorn Hat in a long while though. I have to ask the obvious, did you run the one line installer for the Unicorn Hat?
Do you get any error messages when you run the examples? I like to run stuff like that from idle3 so I can see what’s happening when things go wrong.

I used the following page to setup the HD and there were no errors that I could see either during install or when running the examples - tried a few in that directory.


I think you ran the wrong installer, thats for the original Unicorn Hat. For the HD its
curl https://get.pimoroni.com/unicornhathd | bash