UnicornHat not working


#1

Hi Guys

Being gifted a UnicornHat for my birthday I am eager to get it running. I fitted it to a Pi2 and fed it with a 2A PSU. I installed the libraries using the curl script and, with bated breath, I ran simple.py - instead of the expected cheery magenta glow I was treated to a blinding riot of psychedelic colour. I modified simple.py to be even more simple:

#!/usr/bin/env python

import unicornhat as UH
import time

UH.brightness(0.001) # I don't have welding goggles

for y in range(8):
    for x in range(8):
        UH.set_pixel(4,4,255,0,255)
        UH.show()
        time.sleep(0.05)

time.sleep(1)
UH.clear()

and all I get now is a single GREEN LED lighting up the top right LED (assuming ‘UNICORN HAT’ is printed the right way up).

Is it DOA?

Thanks
Mark


#2

Arrr! I fixed it.

Turns out I had a daemon auto-loaded that wasn’t playing nicely with the Unicorn.

Re-installed on to a vanilla Jessie and everything now works as expected.

I’m off chasing rainbows…


#3

yes, it is worth noting that anything that tries to probe or send signal to the analog audio output will create havoc with the unicorn … not sure if that’s what your deamon was doing, but that’s what came to mind when I read your post.


#4

I really think this should be put on the readme- took me hours to figure out why the UH wasn’t playing ball…


#5

It’s on the product page, but I agree it’s not the best place for it. Regardless I have reworked the installer to route audio to HDMI to try to minimise initial problems.