Newbie with Unicorn Hat install problems


#1

I have the Unicorn Hat attached to the Pi B+ and went to the github repo to get the software. When I run the beginners command (curl get.pimoroni.com/unicornhat | bash), copied and pasted, I get the following error message:

QUOTE
ImportError: No module named ez_setup


Command python setup.py egg_info failed with error code 1 in /home/pi/build/rpi-ws281x
Storing complete log in /root/.pip/pip.log
Python 2 library install failed!
UNQUOTE

Any help would be gratefully appreciated!
Thanks in advance


#2

This error isn’t your fault, but I’m really confused about why it’s cropping up. I removed the “ez_setup” nonsense a couple of versions ago!

Anyway, this should fix it:

sudo pip install rpi_ws281x -I
sudo pip install unicornhat -I

#3

Thank you! It’s installed now.
But still no joy. I cannot get any of the examples to run. For example when I run the simple.py I get:

munmap error -1

Other things run, but no blinkys :(

I am running the Pi headless, using my mac to ssh into it via ethernet. I have swapped the USB power from the USB port to a mains USB adaptor. Nothing. I have even removed the top layer of my PiBow coupe to see if that’s stopping the connection. Still no joy.

I would try with the Pi2, but I’m still waiting for Flotilla to be finished :)


#4

Are you running the examples with “sudo”, ie:

sudo ./rainbow_blinky.py

#5

Oooops.

Yup; “sudo” was there … just not the “./”

I’m learning and WOW - those LEDS ARE bright :0

Thanks for the help