Pi Zero + enviro+ + pms5003 = pin error

The pi zero and enviro+ hat are not working with the pms5003 sensor. Seemingly the GPIO pin detection is not working due to updated libraries - per a discussion on GitHub.

When particulates.py is tried the error output is:

File “/usr/local/lib/python3.9/dist-packages/pms5003/init.py”, line 109, in init
self._pin_enable, self._pin_reset = gpiodevice.get_pins_for_platform(PLATFORMS)
ValueError: not enough values to unpack (expected 2, got 0)

UPDATE - the LCD is not working either. The lcd.py example returns:

Woah there, suitable gpiochip not found!
⚠️ /dev/gpiochip0: 9 is an int and has been skipped, did you mean “PIN9” or “GPIO9”?

Is there any way for a plug and play / cut and paste user like me to fix it? Or is it a matter of waiting until the libraries are updated to fix the problem?

Update - the enviro+ hat works with the pms5003 on a Pi 4, but the lcd screen is not working. Pi zero refuses to work with the pms5003.

Hi, you can get lucky with some fixes posted in this thread, but nothing worked for me so far:

I have posted an update in Issue with Enviro+ with RPi Zero: Display and particles not working - Support - Pimoroni Buccaneers that may resolve this problem.