Sound output for synth cookbook on a Raspberry PI

I have installed the latest flotilla release and firmware from your site on a vanilla 2016-05-27-raspbian-jessie.img, and I can fire up rockpool and get the cookbook examples running OK. However with the Synth module I am unable to get any sound, either via HDMI on my monitor or via an amp plugged into the built in audio out. I can get sound out OK via Sonic-Pi via either route. What do I do to get it working. All the controls seem to work OK, in adjusting the synth values.(using epiphany browser)

Done some further playing. I don’t think the epiphany browser will support sound. If I access the Pi from my mac using chrome browser it works fine. Is this likely to alter?
I have done some sound work with Flotilla hub using the Sniff laugauge and using dial/slider/touch pads to control the playing of wav files and this works fine.

Found a solution.
I installed Chromium 51 on my Pi3 (This will only work on Pi2 or Pi3 NOT on earlier versions of Raspberry Pi).
This browser works fine with the Synth Coookbook.

Instructions were from
I didn’t install the stuff to use this with YouTube eg rpi-youtube, as it is not required to get the synth working, but I guess you can do this too if you want. So the instructions I used were:

wget -qO - | sudo apt-key add -
echo "deb jessie main" | sudo tee -a /etc/apt/sources.list
sudo apt-get update
sudo apt-get install chromium-browser

The first two lines add a key to enable the repository containing an arm compiled version of the browser, then you simply apt-get update and install the browser as for any other app.
The browser will appear as an alternative on the Internet Menu. Use it to access and then you can use the cookbooks you want, including synth.

I was pretty sure that @gadgetoid fixed the issue with no sound output from the synth in Epiphany, but maybe that was the iPad/iPhone problem I’m thinking of?

We’d always recommend using a browser on your Mac/PC/tablet to use Rockpool and Cookbook, as Epiphany is often a bit flaky when it comes to things like this.

I’ve unfortunately found no fix for Epiphany. I just think it’s too old and crusty to handle things like browser audio.