Speaker phat problems

Hi all, I will give a little background and then get straight to my 2 issues.

Hardware: Raspberry Pi 0W and Pimoroni Speaker Phat
OS: Raspbian GNU/Linux 11 (bullseye)
Notes: i2c enabled
Installation process: curl -sS https://get.pimoroni.com/speakerphat | bash

Sound works fine (tested several .mp3 and playlist files like .xspf and .m3u).
LED lights also work nicely (tested them with the “test” python file).
So, at this point I assume my soldering does the job (literally second soldering of my life and the first was a year ago).

Issue 01:
So, I assume a VU meter should be active by default, is that correct? LED lights should do their “Knight Rider” effect while a song is playing, am I right?

Unfortunately, I get only sound (when I run audio files).

In another thread I found this which I already did of course:
sudo nano /etc/pulse/default.pa
Right under the line that reads ### Automatically load driver modules depending on the hardware available
load-module module-alsa-sink device=pivumeter

Any ideas how to enable the VU meter?

Issue 02:
Following this tutorial,

I tried to set cron to automatically play an audio file. Tried with cvlc, ffmpeg and basically 3-4 more cli audio players. Even tried with vlc.

Even though commands work from the terminal, crontab never does.

After a lot of googling (seems a lot of people have the same problem), I learnt about the DISPLAY=:0.0 trick which unfortunately did not work.

So, if anyone got an idea how to combine cron and cvlc, I am grateful.

Thanks a lot for your time!