Speaker Phat sound diminished


#1

Hi
I seem to have a similar topic to
http://forums.pimoroni.com/t/speaker-phat-sound-deterioration/3860?u=jcmjcm

When I ran test.sh for the first time everything worked okay. When l ran again the sound had become barely audible. LED’s still working okay.

Alsamixer indicated playback at level 100
I have rerun the speaker phat installation but this has made no difference


Any suggestions?


#2

A simple suggestion is to try reducing the volume on ALSAmixer to a lower level (in the white usually). Alsa has a funny way of causing issues with some speaker types if the audio level is set to 100%, although this usually only occurs on less-common devices such as outboard sound card or wireless headphones. Worth a try though!


#3

I my case, RMA of the Speaker Phat solved the problem. Replacement still functioning.


#4

The “digital noise” you heard was probably a dry joint on the I2S “Frame Sync” pin. I found this out the hard way yesterday, when I spent ages wiring every ground pin to my test rig (a pHAT BEAT) trying to eliminate a horrible noise issue, and then realised I’d forgot to hook up the “Frame Sync” pin at all. facepalm

@jcmjcm This “diminished” sound is different issue as far as I can guess. It could be a dry joint in the signal path between the AMP and the Speaker itself, or possibly sub-optimal soldering of the speaker to the pHAT.


#5

I have checked soldering and all looks good.

Any further suggestions or do I need to return as faulty?


#6

Speaker soldering


#7

What do you see if you lsb_release -sc ?


#8

Jessie
Is returned
Jeremy


#9

Any further suggestions please?
I have tried the hat with a different Pi ZeroW and the same result so it does appear that the fault is on the Hat


#10

Hi
I ordered a new Speaker Phat yesterday (together with some other toys that fell in my shopping cart!) Received this morning, so fantastic service.
I tried the speaker from the new kit with the old board and can confirm that the volume was back to the original level.
So it is the speaker that has failed.
How can I get the original replaced?
J


#11

Just drop us an email at support@pimoroni.com with your respective order numbers and a link to this thread and they’ll sort it out for you.

Sorry for the lack of response- I’d been putting together a Speaker pHAT/pHAT BEAT test rig for this and other issues, but hadn’t managed to replicate yours. Clearly that’s because it was faulty!