Turning Off Speaker Phat VU meter


#1

I wish to switch off the VU meter and have tried deleting/ modifying the asound file with no luck. I even removed it from the directory and the display keeps working?
I am new to this so any helps or updates that will make this work would be gratefully received. Thanks Graham


#2

Did you restart your Pi/audio software after deleting /etc/asound.conf?

You might also want to try: sudo systemctl restart pulseaudio


#3

Thank you, yes i did a restart and tried the sudo script as you suggested with no luck.
Note: the asound.conf is not deleted its in another directory, is this ok?


#4

That’s… bizarre!

Sure it’s actually moved from the directory and not copied? And not being shadowed by an ~/.asoundrc file (a file named .asoundrc in your home directory, normally /home/pi)

Without the /etc/asound.conf to tell ALSA to use the VU Meter plugin, there should be no VU at all!


#5


The shadowing comment has my interest, please see attached pic. Am I looking in the right place? I’m not sure about “.” after ~/?
The GCV directory is where the asound.conf is.
What is .asoundrc? I have found this and moved it to a temp directory still no luck.
I hope this helps?
Very many thanks for your help
Graham


#6

Oooh, looking at the screenshot it looks like you need to remove the /etc/asound.conf actually installed to your system, ie: if you literally type:

sudo mv /etc/asound.conf /etc/asound.conf.bak

It should do the trick!

The files in the pivumeter directory are only the original versions- these are copied into the right place on your system during install.


#7

Hi Phil,
Magic…that worked a treat. Very many thanks for all your help.
Kind regards
Graham