Unicorn Hat hd and raspberry pi 3 model A +


#1

Hello, I’m trying to use the Unicorn hat hd with new raspberry pi 3 model A + but without success.
I have installed all he software, the in the example dir I run sudo python demo.py, all is ok (no errors shown) but the Unicorn remains dark.

I’m sure that the Unicorn hat works well because I have tested it on a Raspberry py 3 model B v1.2 and it works perfectly.

Are there some incompatibility with raspberry pi 3 model A +?

Any suggestion?

Thanks, Ezio


#2

3A+ should be fine. It’s a 3B+ minus the Ethernet and USB hub etc. It’s missing the USB hub/bridge chip etc.
I’m almost certain I’ve had my Unicorn Hat HD on my 3A+ at least once, and it worked fine with no issues.
My 3A+ is buried deep in another project now though.
Hat pressed down firmly on the GPIO pins?
Hat nice and level?
Nothing touching the underside like the maybe a CPU heatsink?
Good power supply on the 3A+?


#3

All mechanical issues verified more and more.
I have also inserted an insulating sheet between the hat and the raspberry.

Also redone the installation from scratch.

The power supply is a powerbank with enough Amperes.

Any check that I can try?


#4

I don’t know what to look at or for? Phil @gadgetoid might though.
My 3A+ is buried in a PIBOW case with a camera and ninja difusser on the top, currently running Motion Eye OS. I’ll have a look see tomorrow to see if I can plug my Unicorn Hat HD in via a ribbon cable. It’s currently mounted on a Black Hat hacker board. I’ll have to hunt up another Micro SD card too I think?


#5

Just hooked my Unicorn Hat HD up to my Pi 3A+ and it worked. I ran the test.py and it lit up like a Christmas tree. I just took the Micro SD card from the Pi Zero W I had hooked up to it originally and put it in the 3A+. It was fully updated so the 3A+ booted up just fine. No having to redo anything or rerun the installer script.
I have no idea why yours doesn’t work? That was the very latest Raspbian that updated itself via the quick setup GUI. And the one line installer was run for the Unicorn Hat HD.
You ran the correct one line installer right? I ask because there is one for the Unicorn hat and one for the Unicorn hat HD.


#6

Incredible, I was 100% sure to have installed the right software, instead it was the one for Unicorn (non HD)!!!
A right Installation solved the problem.
many thanks to all for all the help.


#7

Ah, problem solved. Thats an easy enough mistake to make. Your not the first one to run the wrong installer. On the plus side no harm is done. Your just left scratching your head wondering why it doesn’t work.
Glad to have helped.