Unicorn Hat not working on Raspberry Pi A+


#1

I am trying to get my Unicorn Hat working on a Raspberry Pi A+. I am running Raspbian Lite (4.9.59+)

After installing the Unicorn software, I get the following message:

RuntimeError: ws2811_init failed with code -3 (Hardware revision is not supported)

I thought it might be related to the distro, so I swapped the SD card with one running on a Pi2 (with a working Unicorn). No dice. Same error.

Any help or advice would be appreciated. I have about 10 of these puppies I am trying to build over the weekend for a Retro Clock I am building.