Adafruit 1.44 TFT - only white screen


#1

Hi there, I purchased these a year ago and tried to get them working with the raspberry pi to no avail; I’m back at it, trying to go from the basics with an arduino uno and I’m still having problems.

The problem I am having, with both of them, is that it only lights up as a bright white screen when VIN is connected to either 3.5V or 5V. However, there is some sort of refreshing happening when the VIN is not connected, so all of the other pins seem to be doing their job.

I’ve look everywhere I can and the only solution seems to be a replacement. Of course I would like to just get these working and will do everything I can to do so!
Thank you in advanced for you help.

Joseph


#2

Judging by the course of this thread, it seems a replacement is necessary:

https://forums.adafruit.com/viewtopic.php?f=47&t=130171&p=647266&hilit=ST7735R

It might be worth running through some of the steps in that thread, though, just in case you get it up and running.


#3

Thank you! I’ll take a look and report back here if it is necessary.


#4

I’ve looked through and tried all of that, afraid it hasn’t fixed the problem, for both of them.


#5

Since they’re likely to know much more about their product than me, please should post this same question on the Adafruit forums to see if they can shed any light on it: https://forums.adafruit.com/viewforum.php?f=47