Adafruit 3.7W Audio Amplifier Not workiing


#1

I can’t get this amplifier to show any signs of life. I have tried different speakers, inputs and I just get nothing. I managed to get the 2.8W amp to show some signs of life but it wasn’t out putting sound either.

I tested the jack by connecting a speaker to the breakout board.
I tested the connections to the RPi with a multi-meter

I have no idea what I need to do to get it working.
The pin-out is setup like so;
VDD - RPi 3v3
GND - RPi GND
SDWN - None
L+ - To Jack tip
L- - To Jack sleeve
R- - To Jack Sleeve
R+ - To Jack Ring 2
G’ - None
G - None


#2

I would try to power the amp from an external 5V source as a first step. Also, I’m not sure, but I think you need the gain jumper fitted, it may not output any sound without it (though that is an assumption rather than certitude).


#3

Well I have some good news, I attached a 5V and ground cable from a usb port on my computer to the amp. I tried it first on the 3.7W nothing happened. But I tried it on the 2.8W that I thought I had killed and I was proven wrong.
So I now have a working amp but not the one was hoping for.