Automation Hat crashes Pi


#1

Hi, I have just plugged an Automation hat onto a Pi 3 which has been freshly updated but I have not yet installed the python libraries. After a fresh reboot, if I connect an Aidafruit PIR motion detector signal wire to buffered input no.1 it crashes the Pi. This is repeatable. The PIR detector supply pins are connected to the hat 5v and ground. I have checked the voltage on the signal wire when not connected, it is 3.2v. I can also hear a relay click at the same time as the crash.
Any ideas anyone?


#2

Update. I have installed the Pimoroni software.
I can run the output.py example ok.
If I run the input.py example and connect a wire from input 1 to 5v as shown in the “getting started” it crashes the Pi.
Is this a duff hat?


#3

It sounds like something is shorting out. Is anything contacting the pins underneath the HAT?


#4

Hi, thanks for your attention.
I can’t see how anything could short. The hat is raised up on a stacking header because there is a heat sink on the CPU but there is about 15mm clearance.
I had one screw in a standoff to stabilise it but I have removed that and still have the problem.


#5

It sounds a lot like you’re encountering a dead short to ground, which is unusual since these HATs are tested and use fairly coarse parts so they’re less prone to failure. Are you able to take a photo of the top of the PCB?


#6

Update.
I have tried with input 2 and 3, they are ok.


#7

Hi, pic…


#8

Another pic…

The Hat came from RS. I have ordered another. I will let you know…
Thanks.


#9

Thank you. I can’t see anything obvious from the top side or guess what could be affecting this input in particular, but that doesn’t mean it’s not a fault with the HAT. However, I’ve tested a couple of hypothesis on my own Automation HAT with no success, so I’m stumped as to what that problem might be!

Keep me posted!