Pi B 3+ Touch Phat -> powers off raspberry


#1

I just got the Touch Phat hat, soldered up and whenever I attach it to the raspberry pi, it shuts off. Having the hat attached to the raspberry and then plugging it in results in no power up, just the red LED light.

It feels like something is crossed / shorting out, but I’ve been unable to detect it. Using a multimeter I checked all the adjacent solder spots and didn’t find any shorted resistance. Perhaps there’s a bette way to check for this. It feels like as soon as PIN 1 and PIN 2 gets connected the PI shuts off . (Pin 1 is the square one right? )

Any ideas on how to trouble shoot this further would be greatly appreciated.


#2

Cody, are you attaching the HAT to a live powered Raspberry Pi?

This is not recommended practice not least of all because the HAT will not be properly detected since that is done at power-up to load the appropriate support.


#3

Among other things I’ve tried, yes. Though the behavior is the same with the raspberry pi off, and the HAT attached, the red LED comes on, but the activity LED never does anything and it sits with a blank screen. I’m assuming it shouldn’t take more than a few seconds to get past that state if everything was working correctly.


#4

check your solder job ,i see a few that show some brass …make sure no solder is touching the next pin ,ect ect


#5

Well I’ve checked / rechecked the solder points. I don’t see any connectivity between adjacent pins (got a nice magnifier to view it better) and took a multimeter as well to the adjacent pins, the resistance is all there. When I have the pi shut down, and I plug this in, if I was to then unplug it, the PI powers on, which is kinda weird. it’s like the oppisite of what happens when you short 5 and 6, to power it on. The pi wont power on until the HAT is removed. Not sure what else to try other than another board, which is a bit sad.


#6

Have you tried re-soldering them? Don’t add any more solder, just get the board warmed up and let each joint reflow in turn.

It sounds like a short between 3.3v and GND, you should check for shorts between those pins rather than adjacent ones. (And between 5v and GND for good measure)

Also make doubly sure you’re putting the HAT on the right way 'round! It sounds condescending, but I’ve seen it happen.

You can find the power and ground pin locations here: https://pinout.xyz/


#7

Gave that resolder a go. I don’t see any bridged solder joints on the top. I’m not sure if there is a better way to test this, but just using a multimeter I see that between pin 1 (3.3V) and any of the ground pins there is no resistance / connectivity. I see the same with pin 2 and 4 (the two 5v pins) I’m unsure if thats expected, perhaps there is supposed to be connectivity (guessing thats what having no resistance measured between these pins mean) or perhaps thats my issue, but I don’t see any bridged connections on the top of the HAT between pin 1 and any of the ground pins. ( I take it all the ground is connected)

If I understand the pinout diagram correctly, this thing is only using pin 1, 2, 3, and 5. the 3.3v, 5v and the two gpios for I2C.

My last guess is somehow the solder leaked down through the pin hole and is bridging on the underside of the 40 pin thingy. Will try desoldering it and taking a look at whats going on.


#8

Well either the board is bad or the pi is bad. I removed the 40 pin, got all the solder off, dropped it onto the break out and the same behavior. (also seeing the same connectivity between 3v and ground with no connections there) I can’t think it’s a bridged solder job at this point, cause there isn’t any solder on the thing.