[Solved]ExplorerHAT Pro Blue LED failure


#1

Hi,

I received two days ago an ExplorerHAT Pro. I installed it today and run test.py. I realized that the blue LED was on during the first try of the loop but in the next ones it was off or was blinking with low intensity. I checked the program to see if there is a kind of intensity regulation on test.py, after no seeing it I decided to write a simple program to turn on all the lights during one minute.

After a few seconds (can measure, if needed) blue LED was off, and started blinking with low intensity.

I am using a, I think properly soldered, Black Hack3r HAT to connect it so I changed the HAT to other pin row and the same happened.

Any idea? Thank you!


ExplorerHAT Pro blue LED not working
#2

I’m no expert but if it lights up at all I’d say the most likely is a bad solder point if your set up, i.e Black HAT. Any way you could try to connect the HAT direct to the Pi (via link up cable if needs be)?

If not then try to touch up all 3 instances of pin 7 (BCM4) on the Black HAT, which is the pin relevant to the blue LED.


#3

RogueM makes a good point! Also possible that the GPIO cable is faulty. How good is your power supply by the way? Can you measure the 5V rail while running your test?

The reason I question the power supply is that the forward voltage of blue LEDs tends to be higher than others so if your GPIO pin is faltering (which is supplied by the 3V3 regulator that draws from the 5V input USB) it may only affect that LED.


#4

Thank you both for your answers.

I have been checking the pinout and comparing with the SenseHat, which worked properly last time I tried, but this is not a common pin among these two HATs.

I won’t be able today, but I’ll attach it directly to the Pi just in case. If it works, use a T-Cobbler that I have to check that it’s not the cable and if it works check the soldering of the Black HAT Hack3r. I’ll post my results once it’s done, hope to be able to do it tomorrow.

Just a question, how could I check pin by pin that the Black HAT Hack3r is properly soldered? I believe that checking the continuity or measuring the output voltage with a multimeter but I want to be sure before testing.


#5

If it is the soldering then it appears to be a poor/intermittent joint. Continuity testing won’t be ideal as it might beep one minute and not the next.

Really you’d want to get a scope hooked up to it and measure it over time I guess while manipulating the header to attempt to force the fault to present itself.


#6

I just realized that, as I tried in both rows of the Hack3r, or I am too bad at soldering hahahaha or the pin with the failure should be the one attached to the cable (or the cable). I’ll check everything, though.


#7

Yes, ensuring all the solder points are kosher is the not-so-fun part of assembling the Black HAT, but since it is a multipurpose tinkering sketchpad it is worth the effort and will save you time further down the line.

… I’ve got 2 sitting in front of me right now and I’ve been putting this off for a few days.


#8

Any example of how to test ithe soldering t’s good? I am newbie (specially to soldering), you already realized I’m sure hahaha, and English is not my mother tongue so I need, not a step-by-step, but slightly more developed information to do things.

Thank you!


#9

Feel free to post a photo of the solder joints!

Another avenue worth exploring is hooking up a standard LED directly to the same GPIO pin and seeing if it behaves the same, perhaps that GPIO pin is damaged.

This is a fun one to debug…


#10

For testing the Black HAT soldering my method is to use a LED bus I have lying around to test 4-6 pins in one go, which is essentially a continuity test but as Jon pointed out it’s pretty crude method.

… the Black HAT was the very first thing I ever soldered and really I only consider myself good enough 6 months down the line to tackle another one, 120 pins to get right (a significant number being ground) is no small feat.

Honestly, the best way IMO for your issue is to eliminate the Black HAT out of the equation until you figured out whether the fault is not elsewhere. If you come to doubt the soldering look up the pinout for your hardware and touch up the points when problem arise.


#11

One tip I can give you though is to use a magnifier to inspect your work. It will not only allow you to fix potentially dodgy joints ahead of them making your life a misery, but you’ll learn a lot about soldering and how much solder to use.


#12

Thank you both for the tips.

I first soldered some broken PCB’s and then, when I felt confortable enough with soldering, tried the HAT. Some points are not too beautiful, but I think is not completely bad.

I’ll try tomorrow somethings and post here.


#13

Bad news for me :(

Tested directly on the Pi -> Failed
Tested a LED directly on the Pi -> Failed
Tested a LED directly on pin 17 -> Worked.

This Pi wasn’t bought here (I didn’t know you yet). Do you recommend me contacting the seller or checking the pins are correctly soldered?

Edit: took the Pi out of the box and checked the pins, nothing rare. It is like it couldn’t supply the voltage for more than a seconds. For example I run the code for 20 seconds and it lights for 6, then is off. I run again, without touching the pins and it can light again but only for a few seconds.

Edit 2: after running to Raspberry Pi forums and posting my problem I did what I should have done on the beginning, search and try to solve it. Found this https://www.raspberrypi.org/forums/viewtopic.php?f=91&t=112560 and, as I started with a CamJam EduKit (I’m adult but looked, indeed it is, an interesting way to learn the basics) I had that temperature sensor attached. I’ll try in a while.

Edit 3: solved with the information from the topic I put before, removing the temperature sensor from the boot config.

Thank you, Jon and RogueM for your help.

Regards


#14

You are more than welcome, glad you got it fixed and thanks @RogueM for his input too! :-)