Unicorn Hat LEDs not lighting up

I just got the Unicorn Hat in the mail today, I attached it to my Pis 3 pins but no lights. I followed the beginner’s guide and installed all the dependencies and all but still no lights. Is there something else I’m missing?

What happens when you run one of the python example files?
And are you running them with sudo?

Hi, when I run it with sudo the command script runs without errors but no led lights appear. Ive tried all the examples. I uploaded a picture of the LED with the Pi, I just attached it. No soldering is needed right? Also as a side note I read that once you plug in the HAT it should light up, mine did not.

No soldering is needed, but it shouldn’t really light up when you attach the board. In fact, you’re better off attaching the board when the Pi is powered down, just to avoid accidentally shorting anything.

If the examples seem to run fine, without errors, but nothing lights up then that’s not a great sign. Does an example like random_blinky.py still print messages to the terminal?

Make sure nothing is touching the back side of the Unicorn Hat. Anything metal like a heatsink could short something out.

I have a Unicorn HD, and the Mini HD. Neither one lights up until I run code to tell it to light up.

Yea there is a gap between the sink and PI

So my examples did not come with random_blinky.py. I copied the script and boom it works, the first few LEDs light up. Im assuming there’s something in the pre examples that are missing.

Glad you’ve got signs of life now, there is a whole list of examples here on their Git page.

Yea I’ve been fiddling around with scripts and such and it’s always the first 4 pixels. I think the rest of the lights are dead. R.I.P

It only uses 3 GPIO pins and two of those are for power, so I wouldn’t think its an issue with the Pi. Not a hardware issue anyway.
It only uses the 1 data pin so I’m thinking they work like NEOPIXELs. And one of them, the first one that doesn’t light up (or the last one that does) has an issue.
Unicorn HAT at Raspberry Pi GPIO Pinout

My two Unicorn boards are both HD and use SPI, I can’t try any of the examples your using.